5

I can not configure the RSVP between Cisco6509 SUP2T and Juniper MX480. Prior to that set up the neighbor 3 without problems. Now that it is impossible ...I do not understand why :(

scheme: Cisco t5/5 trunk > Extreme670> Juniper MX480.

side MX

admin@M10_MX480> show configuration interfaces xe-1/0/2.29 
vlan-id 29;
family inet {
    address 185.13.115.89/31;
}
family mpls;

{master}
admin@M10_MX480> show configuration protocols | display set | match xe-1/0/2.29 
set protocols rsvp interface xe-1/0/2.29
set protocols mpls interface xe-1/0/2.29
set protocols ospf area 0.0.0.0 interface xe-1/0/2.29

{master}
admin@M10_MX480>

Side Catalyst

MED-C6509#sh run int vlan 29
Building configuration...

Current configuration : 155 bytes
!
interface Vlan29
 mtu 8978
 ip address 185.13.115.88 255.255.255.254
 ip ospf 1 area 0
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp signalling hello
end

MED-C6509#sh run | s ospf
router ospf 1
 router-id 172.16.16.5
 auto-cost reference-bandwidth 1000
 network 172.16.16.5 0.0.0.0 area 0  <<<< Loopback
 network 195.128.59.172 0.0.0.3 area 0
 network 195.128.59.176 0.0.0.3 area 0
 mpls traffic-eng router-id Loopback3
 mpls traffic-eng area 0
MED-C6509#sh run | s rsvp
 ip rsvp signalling hello
 ip rsvp signalling hello
 ip rsvp signalling hello
 ip rsvp signalling hello
 ip rsvp signalling hello
ip rsvp signalling hello
MED-C6509#

but other RSVP-hosts relationships OK

MED-C6509#sh ip rsvp neighbor 
Neighbor        Encapsulation  Time since msg rcvd/sent
185.13.115.78   Raw IP         00:00:01   00:00:01  
185.13.115.82   Raw IP         00:00:01   00:00:01  
195.128.59.174  Raw IP         00:00:01   00:00:01  

* Neighbors inactive for more than one hour are not shown.
  Use the "inactive" keyword to display them.
MED-C6509#
  • Do those other RSVP relationships take the same path (through a trunk over a VLAN)? – Jordan Head Apr 15 '15 at 20:12
  • all over SVI ( vlan) – Артём Лисенков Apr 16 '15 at 15:42
  • 2
    Do you have traffic engineering extensions turned on in the ospf config on the MX480? set protocols ospf traffic-engineering shortcuts Also: set protocols mpls traffic-engineering mpls-forwarding Juniper is a lot stricter on prerequisite config than Cisco. – Firebirdnz Apr 17 '15 at 4:51
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 11 '17 at 15:17
1

From Junos MPLS and VPNs Student GUide Volume 1 of 3 revision 12.a

Basic functional RSVP configuration requires:

1.Adding the mpls family to desired interfaces (not needed for lo0)

2.Linking interfaces with the routers MPLS process

3.Enabling RSVP on desired interfaces

4.Configure the label-switched-path under the protocols mpls hierarchy

As your outputs fall short, and the config given was displayed set|match I can only say based on the evidence you have provided that you are missing point 4. One common mistake I would add is also not having configured no-cspf under mpls stanza.`

`

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.