0

My setup is as follows:

[internet] - Netgear FVS318N Router - Netgear GS752TP Smart Switch

FVS318N port 1 connects to port 39 on GS752 Smart Switch WNAP210 connects to port 48 on GS752 Smart Switch

On GS752, VLAN10 is set to: port 39 as T, and port 48 as U.

On FVS918, I have configured two subnets with DHCP, one for VLAN1 and another for VLAN10.

Now, if I plug in a laptop to port 48 on the switch (as opposed to the WNAP210), the laptop gets an IP in the VLAN10 range and can browse the internet.

If I plug in the WNAP210, and connect a laptop to it wirelessly, the laptop gets an IP n the VLAN10 range, but can not browse the internet.

The WNAP210 has a System > Advanced page where the option is to set:

  • 802.1Q VLAN
  • Untagged VLAN (checked or not), with a VLAN ID

I've tried every combination on that page, and still the same result. Wondering if I need to configure a route on either the FVS318 or the GS752.

ROUTER
enter image description here enter image description here enter image description here enter image description here enter image description here

SWITCH enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

AP enter image description here enter image description here enter image description here enter image description here


12
  • Please consider adding more details; we need to see your AP and switch configurations – Mike Pennington May 4 '15 at 8:08
  • What is the IP address and default gateway address you get on your laptop when you are plugged into the switch? Is it the same when you are wireless? – Ron Trunk May 4 '15 at 12:58
  • I'll upload screenshots later today. The FVS318 has an IP of 10.0.0.1 and 10.0.10.1. The switch has 10.0.0.2. If I plug in to any port but 48, I get an address of 10.0.0.x with gateway of 10.0.01, on port I get 10.0.10.x with a gateway of 10.0.10.1. When I plug in the AP, it gets an ip of 10.0.10.x with a gateway of 10.0.10.1. I have tried setting the Untagged VLAN to checked with a value of VLAN10, as well as unchecked. – John May 4 '15 at 14:04
  • With the AP plugged into port 48, if on the switch, I set port 48's PVID to 1, I get an IP on VLAN1 and can browse the net, etc. If I revert port 48's PVID to 10, I get the problem I am describing. – John May 4 '15 at 14:06
  • Added screenshots from what I can gather are all of the pages that matter... – John May 5 '15 at 0:22
2

You have a gateway (security appliance / router), a switch, and an access point. You want 4 VLANs - default, voice, video, and guest.

You need to configure each of these VLANs with a unique subnet and IP address in your gateway. The IP address assigned to the gateway is the default gateway for each VLAN/subnet.

The switch and AP should have a management IP address assigned to them from the default VLAN/subnet (e.g. 10.0.0.1 in your case) and their default gateway is the IP address of the gateway.

10.0.0.1/24 = gateway 10.0.0.2/24 = switch 10.0.0.3/24 = AP

OK, now: how to connect the gateway and AP to the switch. Trunk ports are necessary to carry the multiple VLANs to the AP and gateway. The AP needs to see all VLANs so it can assign clients to either default or guest, as does the gateway (so it can route between the VLANs/subnets).

Configure trunking to both AP and gateway. 802.1q should be an option and your default vlan should be VLAN1.

Your AP will need to have unique SSID's per VLAN/subnet with each it's own security policy.

Your gateway will need to have NAT/PAT enabled.

Does that help?

2
  • I connected the gateway to the switch with a single cable. On the switch, I set the ports that have the cables to the gateway and AP to T (PVID of port going to gateway = 1 and PVID for port going to AP = 10) for VLAN10. From VLAN1, everything is OK. From the laptop connected to the AP n VLAN10, I can ping the gateway, but not the switch or the internet. – John May 6 '15 at 23:59
  • You need to be trunking on both ports - trunking to the gateway and trunking to the AP. So, there is no single vlan assigned to either of those ports / links. Those links need to be setup as trunk links. – Ronnie Royston May 7 '15 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.