0

Please look at the attached topology

enter image description here

I am studying for CCNP with ine.com, and I have got a lab switch they say is possible, I say it is not (with the current config)

SW-3 config

Fa 0/15
no switchport
ip address 1.1.1.33

Fa 0/14
switchport trunk encapsulation dot1q
switchoort mode trunk

Fa 0/3
switchport mode access
switchport access vlan 111

SW-1 config

Fa 0/15
switchport mode access
switchport access vlan 111

Fa 0/11
switchport mode access 
switchport access vlan 111

Fa 0/14
switchport trunk encapsulation dot1q
switchoort mode trunk

SW-2 config

Fa 0/11
no switchport
ip address 1.1.1.22

R3

Fa 0/1
ip address 1.1.1.111

The problem

SW-3 Fa0/15 generates an icmp packet headed for 1.1.1.111 (which is R3), it never makes it. (This is indicated by the red line)

SW-2 Fa0/11 generates an icmp packet headed for 1.1.1.111 (which is R3), it makes it. (This is indicated by the blue line)

SW-1, SW-3, SW-2 all have ip routing enabled.

If R3 generates the packet, heading for 1.1.1.33 (SW-3 int Fa 0/15) when the packet gets to SW-3, I believe the switch looks at its cef table and sees that 1.1.1.33/32 has received beside it not attached. So it thinks that the packet is for itself, and does not attempt to forward it out any interface.

I think this is somehow causing conflict, as the packet needs to be forwarded out Fa 0/14 and then back in Fa 0/15

If anyone could point me in the right direction I would be very grateful.

3
  • Do you have an SVI built for vlan 111 on SW-3?
    – cpt_fink
    May 7, 2015 at 6:34
  • No svi? Not sure why i need one. When the packett leaves SW-3 on Fa 0/15 it gets tagged by SW-1 Fa 0/15 access port, vlan 111, then trunked back out Fa 0/14
    – psniffer
    May 7, 2015 at 8:22
  • I don't think you do need one, but if you had an SVI on a vlan with a packet destined for the switches own mac-address it could cause interesting results.
    – cpt_fink
    May 8, 2015 at 1:14

1 Answer 1

0

Im sure this is a limitation with the 3550.

SW-3 is the 3550, i have just used a 3560 and it works fine.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.