-2

I am running OpenVPN server on my DD-WRT router at home. When I ssh into a home server, which is running an OpenVPN client behind that home router and disable ARP on it (ip link set dev arp off, arptables), the server is no more accessible. The SSH tunnel just hangs, no HTTP is served anymore, it doesn't even respond to ping. Why is that? Can it be worked around?

2
  • Thank you for asking; unfortunately this question seems to be about home / consumer networking. Both home networking and consumer class devices are off-topic here. Super User is the right place to ask this question; rest assured that several of our members answer there too. May 26, 2015 at 14:15
  • OK. The question turned out to be wrong anyway - when I got home, I tried to disable it from LAN and it did the same thing, without OpenVPN in the way.
    – bremby
    May 26, 2015 at 19:26

1 Answer 1

2

Because ARP is what is needed at the link layer of your network to find your server, so you have to keep it on. ARP is used to resolve an IP adresse to a MAC address on the local network.

Edit by OP: the reason was really ARP, but the fact the server's ARP cache was being flushed right away.

2
  • Nope. The SSH tunnel hangs right away, there's no delay. For ARP there's a cache so that would not clear right away. Also, it only affected me, not the other person who was working with the server normally.
    – bremby
    May 26, 2015 at 19:25
  • 2
    When disabling ARP, the ARP cache is flushed ... And what's the point in trying to debug a break in a connection after disabling the essential part of it ... you should disconnect the network cable of your server, unplug the power and wonder why it doesn't answer at all ... May 26, 2015 at 20:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.