1

Topology

My goal is R1 successfully redirects www (port 80) packets to the Proxy1, i already setup the Host3 as Client with gateway 192.168.60.4/24(port fa1/0.60 on R1)

i'm working with different VLANs so i'm following the explanation from this link WCCP with different VLANs

so i applied this config to the R1 port f1/0.60 - (Connected to VLAN 60/Client VLAN) :

interface FastEthernet1/0.60
 encapsulation dot1Q 60
 ip address 192.168.60.4 255.255.255.0
 ip wccp web-cache redirect in
 ip nat inside
 standby 60 ip 192.168.60.2
 standby 60 priority 170
 standby 60 preempt delay minimum 30

here's the f/10.20 (Connected to VLAN 20/Proxy1) config :

interface FastEthernet1/0.20
 encapsulation dot1Q 20
 ip address 100.10.20.1 255.255.255.0
 ip nat inside
 standby 20 ip 100.10.20.2 
 standby 20 priority 120
 standby 20 preempt delay minimum 30

and this is the ACL I used to determine the Proxy network and Client network

access-list 10 permit 100.10.30.3
access-list 10 permit 100.10.20.3
access-list 120 permit tcp any any eq www
access-list 120 deny   ip any any

Proxy1 had an ip address 100.10.20.3 and here's the squid.conf config :

http_port 3128 transparent
wccp2_router 100.10.20.1
wccp2_forwarding_method gre
wccp2_return_method gre
wccp2_assignment_metod hash
wccp2_service standard 0
acl localnet src 192.168.60.0/24, 100.10.20.0/28, 10.42.12.0/24, 120.100.10.0/28

The problem is, Router R1 doesn't redirects any packet to Proxy1 while I'm trying to access any website on internet via Host3.

Thank you,

Tech Specs : Mac OS X 10.9.5 - GNS3 1.3.3 - 3600 IOS Cisco Router

3
  • How have you verified that no packets are bing redirected, have you used the wireshark captures on the links for examples?
    – jwbensley
    May 28 '15 at 10:15
  • sorry, my fault, i was missing one line on iptables config. It was causing redirected packets got stuck in the squid after exiting from the GRE tunnel.
    – fma-46
    May 30 '15 at 7:28
  • @fma-46 So the problem is fixed now? Can we remove this question? Jun 5 '15 at 22:28

Browse other questions tagged or ask your own question.