3

1) I am able to create VLAN on Juniper QFX5100 but when I am assigning interface to that VLAN it is showing an error "family ethernet-switching and other families are mutually exclusive"

Command used is

set vlans Customer1 vlan-id 11

set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members Customer1

On this interface I have already configured IP address

2) But when I am creating vlans on some other port with nothing configured on it, I am able to create the vlan

Command used is

set vlans Customer1 vland-id 11

Set interfaces ge-0/0/20.0 family ethernet-switching vlan members Customer1

This interface does not have any IP address configured on it.

And 1 more thing I would like to add is in 2nd query in commands if I am not adding .0 to the interface (i.e. ge-0/0/20.0) it will not showing me option of family after interface ge-0/0/20.0

Please help me to resolve this issue as i am just new to Juniper.

  • Could you post your full configuration, please? – Jordan Head May 30 '15 at 12:45
  • 1
    Sorry, full interface configuration - "show configuration interfaces" – Jordan Head May 30 '15 at 12:47
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 11 '17 at 16:59
2
 family ethernet-switching and other families are mutually exclusive

You're using too many parameters under the family stanza. This extra parameter is family inet based on this:

”On this interface I have already configured IP address.”

Run user@qfx5100# delete interfaces ge-0/0/0.0 family inet. Optionally, you could delete all of ge-0/0/0.0 with user@qfx5100# delete interfaces ge-0/0/0.0 and then put your configurations back in.

When running show interfaces and show vlans, you should see this:

interfaces {
    ge-0/0/0 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Customer1;
                }
            }
        }
    }
    ge-0/0/20 {
        unit 0 {
            family ethernet-switching {
                vlan {
                    members Customer1;
                }
            }
        }
    }    
}
vlans {
    Customer1 {
        vland-id 11;
    }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.