1

I have built a MultiVRF test scenario, it's working as intended but my question is, how?

It's a tricky scenario, the VRFs between CE and PE have different RT and RD.

Sceneario

Here are the configs

R1:

ip vrf RED
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1  
!
interface Loopback900
 ip vrf forwarding RED
 ip address 1.1.1.1 255.255.255.255
!

interface FastEthernet0/0.900
 encapsulation dot1Q 900
 ip vrf forwarding RED
 ip address 192.168.0.2 255.255.255.252
!

router bgp 65000
 address-family ipv4 vrf RED
  neighbor 192.168.0.1 remote-as 3352
  neighbor 192.168.0.1 activate
 neighbor 192.168.0.1 send-community extended

  no synchronization
  network 1.1.1.1 mask 255.255.255.255
 exit-address-family

R2:

ip vrf RED
 rd 3352:50
 route-target export 3352:50
 route-target import 3352:50
!

interface Loopback900
 ip vrf forwarding RED
 ip address 2.2.2.2 255.255.255.255
!

interface FastEthernet0/0.900
 encapsulation dot1Q 900
 ip vrf forwarding RED
 ip address 192.168.0.1 255.255.255.252
!
 address-family ipv4 vrf RED
  neighbor 192.168.0.2 remote-as 65000
  neighbor 192.168.0.2 activate
  neighbor 192.168.0.2 send-community extended
  no synchronization
  network 2.2.2.2 mask 255.255.255.255
 exit-address-family
!

R1#sh ip bgp vpnv4 all 2.2.2.2
BGP routing table entry for 65000:1:2.2.2.2/32, version 6
Paths: (1 available, best #1, table RED)
Flag: 0x820
  Not advertised to any peer
  3352
    192.168.0.1 from 192.168.0.1 (2.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Extended Community: **RT:65000:1**
      mpls labels in/out 16/nolabel

R1#ping vrf RED 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/36 ms

R2#sh ip bgp vpnv4 all 1.1.1.1
BGP routing table entry for 3352:50:1.1.1.1/32, version 5
Paths: (1 available, best #1, table RED)
Flag: 0x820
  Not advertised to any peer 65000
    192.168.0.2 from 192.168.0.2 (172.16.1.1)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Extended Community: RT:3352:50
      mpls labels in/out 18/nolabel

So from R2's perspective I see 1.1.1.1 with 3352:50 even though R1 is exporting the route with 65000:1.

Why do I see on each router the vpn4 route with its own RD and RT?

Maybe there is something obvious I'm missing but I can't seem to find the answer.

1

The behavior you are seeing is expected, since you're not using MPLS-tagged interfaces and the vpnv4 address family.

Since you are using standard iBGP the extended communities attached to the routes are only informational, not used for actual route importation. Also the link between PE and CE is normally plain IP traffic (not MPLS tagged), so it looks like the lab you are working from might be confusing several different steps.

| improve this answer | |
  • Hi, thanks for the explanation. l'll try to complete the configurations implementing MPLS. Actually that topology is being used in a production network, just wanted to replicate it because i didnt understand the logic behind, i was trying to establish the same logic used in PE-PE communication. – Akiles Jun 2 '15 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.