2

Diagram

The core1 is able to reach R1 and R2 connected interface and loopback0 interfaces. The problem is that R1 cannot reach R2's loopback and vice versa. Each device is able to hit each others physical interfaces.

    R1 - loopback0 10.x.x.1/32
    Router EIGRP 1
    network 10.x.x.1 0.0.0.0
    network 10.x.x.2 0.0.0.0
    network 10.x.x.3 0.0.0.0
eigrp router-id 10.x.x.1
    no auto-summary

    R2 - loopback0 10.x.x.2/32
    Router EIGRP 1
    network 10.x.x.1 0.0.0.0
    network 10.x.x.2 0.0.0.0
    network 10.x.x.3 0.0.0.0
eigrp router-id 10.x.x.2
    no auto-summary

    Core1 - loopback0 10.x.x.3/32
    Router EIGRP 1
    network 10.x.x.1 0.0.0.0
    network 10.x.x.2 0.0.0.0
    network 10.x.x.3 0.0.0.0
    eigrp stub connected summary
eigrp router-id 10.x.x.3
    no auto-summary

It seems to me that Core1 is not passing its knowledge of R1 and R2's loopbacks.

  • Could you provide outputs of "show ip route" and "show ip eigrp topology" from all the devices? And just a passing note, is it really necessary to obfuscate RFC1918 private addresses? – Robert Jun 3 '15 at 16:28
  • is there a "redistribute connected" option under eigrp config mode? – Ron Royston Jun 3 '15 at 17:50
  • @RonRoyston Yes, on the core. But not on R1 and R2. – HAL Jun 3 '15 at 17:52
  • put that in the config and give 'er a try. Let us know if that get's those routes in there. – Ron Royston Jun 3 '15 at 17:54
  • Done. Routes are being "denied by stub". Seems to me like the stub configuration I cannot remove is limiting my ability to pass the loopback. I can pass the physical interface routes without issue. – HAL Jun 3 '15 at 17:56
2

Remove the eigrp stub connected summary from the Core1 router.

An EIGRP stub router should not be a router that carries transit traffic (from R1 to R2). The options you specify on the stub command 'connected' and 'summary' mean that it will only advertise connected routes (the physical) and summary routes (which you don't specify having configured).

  • You cannot remove the eigrp stub connected summary command from Core1. It is a layer 3 switch, 3750G. – HAL Jun 3 '15 at 17:40
  • 1
    IP Base only supports EIGRP stub routing on that platform. – Robert Jun 3 '15 at 18:04
  • 3
    IP services would allow full EIGRP routing. – Robert Jun 3 '15 at 18:19
  • 1
    This answer is correct, to my knowledge. I however, resolve the issue with a layer 2 switch module on my routers, linking them together with a /30 vlan. – HAL Jun 3 '15 at 19:29
  • 1
    Static routes on R1 and R2 would have also been a workaround. That's an unfortunate limitation of IP Base, but I'm glad you resolved it. – Robert Jun 3 '15 at 19:42
0

You can overcome this by using a leak map.

ip prefix-list LEAKED_ROUTES permit x.x.x.x/x
route-map EIGRPSTUB_LEAK permit 10
match ip address prefix-list LEAKED_ROUTES
router eigrp 1
eigrp stub connected leak-map EIGRPSTUB_LEAK
  • Welcome to NE, we hope you will both contribute to and learn from this community. Don't worry if you can't figure out the formatting. Since SE is community moderated, anyone can at least propose edits so things like this tend to get fixed quickly and easily. – YLearn Jun 3 '15 at 22:13
  • Also adding what you are overcoming is helpful. – cpt_fink Jun 4 '15 at 3:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.