3

I am troubleshooting intermittent connectivity issues towards a WLC connected to a stack made of three 3750G switches. Part-number and software version of the switches are:

Switch   Ports  Model              SW Version              SW Image
------   -----  -----              ----------              ----------
     1   12     WS-C3750G-12S      12.2(35)SE5             C3750-IPBASE-M
*    2   52     WS-C3750G-48TS     12.2(35)SE5             C3750-IPBASE-M
     3   52     WS-C3750G-48TS     12.2(35)SE5             C3750-IPBASE-M

WLC has LAG enabled, so Po4 has been configured in the stack including 4 ports to connect the 4 physical ports of the WLC:

SW#show etherchannel 4 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
4      Po4(SU)          -        Gi2/0/51(P) Gi2/0/52(P) Gi3/0/51(P)
                                 Gi3/0/52(P)

SW#

Configuration of the physical and portchannel interfaces is:

interface GigabitEthernet2/0/51
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust cos
 channel-group 4 mode on
end
!
interface GigabitEthernet2/0/52
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust cos
 channel-group 4 mode on
end
!
interface GigabitEthernet3/0/51
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust cos
 channel-group 4 mode on
end
!
interface GigabitEthernet3/0/52
 switchport trunk encapsulation dot1q
 switchport mode trunk
 mls qos trust cos
 channel-group 4 mode on
end
!
interface Port-channel4
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

Ethernchannel load-balance is done based on source and destination IP addresses:

SW#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-dst-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
  IPv4: Source XOR Destination IP address
  IPv6: Source XOR Destination IP address

SW#

During troubleshooting, I have tried disabling 2 of the 4 ports of the etherchannel and have found that sometimes the switch is trying to forward traffic through ports that are disabled:

SW#show etherchannel 4 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 4
Number of aggregators:           4

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
4      Po4(SU)          -        Gi2/0/51(D) Gi2/0/52(D) Gi3/0/51(P) 
                                 Gi3/0/52(P)
SW#
SW#
SW#
SW#test etherchannel load-balance interface Po4 ip 10.0.1.254 10.0.1.251
Would select Gi2/0/52 of Po4  
SW#

I understand etherchannel load-balance should never try to forward traffic through ports being down or disabled, even if the ports are configured to be part of the etherchannel.

Does any of you know any good reason for this behaviour?

2
  • 2
    My guess is that the test command is providing a simple test for how the load balancing would take place under your configured parameters, not based on live conditions. However I couldn't find any documentation to back this up.
    – YLearn
    Jun 8, 2015 at 23:30
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Nov 19, 2022 at 21:41

1 Answer 1

-1

Traffic will still go through the 2 ports.

Make sure:

speed/duplex match

protocols match

one side initiates protocol communication

1
  • This doesn't address the concerns of the OP at all. OP disabled the two ports himself, and is asking about the results from the test command selecting a disabled port.
    – YLearn
    Jul 8, 2015 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.