4

Topology:

sw3560  gig0/23 ---> fa0/24  sw2960
sw3560  gig0/24 ---> gig0/2  sw2960 

I have a question regarding to STP load balancing, on my switch 3560 I configure the following:

!
interface GigabitEthernet0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 200
 switchport mode trunk
 spanning-tree vlan 10,20,30,40,50,60 port-priority 16
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 200
 switchport mode trunk
 spanning-tree vlan 70,80,90,100,150 port-priority 16

is this a right configuration??

thank you...

 VLAN0001
   Spanning tree enabled protocol ieee
   Root ID    Priority    32769
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0010
   Spanning tree enabled protocol ieee
   Root ID    Priority    32778
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0020
   Spanning tree enabled protocol ieee
   Root ID    Priority    32788
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0030
   Spanning tree enabled protocol ieee
   Root ID    Priority    32798
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0040
   Spanning tree enabled protocol ieee
   Root ID    Priority    32808
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32808  (priority 32768 sys-id-ext 40)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0050
   Spanning tree enabled protocol ieee
   Root ID    Priority    32818
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32818  (priority 32768 sys-id-ext 50)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0060
   Spanning tree enabled protocol ieee
   Root ID    Priority    32828
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32828  (priority 32768 sys-id-ext 60)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19         16.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p

 VLAN0070
   Spanning tree enabled protocol ieee
   Root ID    Priority    32838
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32838  (priority 32768 sys-id-ext 70)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4          16.24   P2p

 VLAN0080
   Spanning tree enabled protocol ieee
   Root ID    Priority    32848
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32848  (priority 32768 sys-id-ext 80)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4          16.24   P2p

  VLAN0090
    Spanning tree enabled protocol ieee
    Root ID    Priority    32858
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32858  (priority 32768 sys-id-ext 90)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4          16.24   P2p

 VLAN0100
   Spanning tree enabled protocol ieee
   Root ID    Priority    32868
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/12              Desg FWD 19        128.12   P2p
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4          16.24   P2p

  VLAN0150
    Spanning tree enabled protocol ieee
    Root ID    Priority    32918
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32918  (priority 32768 sys-id-ext 150)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4          16.24   P2p

 VLAN0200
   Spanning tree enabled protocol ieee
   Root ID    Priority    32968
         Address     0018.18da.8b80
         Cost        4
         Port        24 (GigabitEthernet0/24)
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

         Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
         Address     0019.5601.7600
         Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
         Aging Time  300 sec

         Interface           Role Sts Cost      Prio.Nbr Type
         Gi0/23              Altn BLK 19        128.23   P2p
         Gi0/24              Root FWD 4         128.24   P2p
8
  • 2
    We need way more detail. Jun 9 '15 at 10:42
  • sw3560 gig0/23 ---> sw2960 fa0/24 sw3560 gig0/24 ---> sw2960 gig0/2 Jun 9 '15 at 11:19
  • I think what Jordan is asking about is what exactly you are trying to achieve and what problems are you having? Jun 9 '15 at 14:00
  • He has a single 3560 uplinked to a single 2960, one link is gig, the other fast ethernet. He wants vlans 10,20,30,40,50,60 to ride the fe link during normal operation and fail to the gig if fe dies. STP no good. Jun 9 '15 at 17:05
  • good day to all, sorry for not understanding. my goal is to have a backup link if the other link fails. if there any suggestion what configuration do i have to do pls guide me sir. Jun 10 '15 at 1:12
3

For lack of a question, I'll assume the following.

Is this working the way I intend on making it work?

Unfortunately, it's not. Spanning-tree has selected Gi0/24 on each port because it's a lower root path cost, so it isn't taking the spanning-tree port-priority into account. When STP making it's calculations, it follows these orders.

  1. Root Bridge Identifier, the Bridge Identifier of the Bridge believed to be the Root by the transmitter
  2. Root Path Cost, to that Root Bridge from the transmitting Bridge
  3. Bridge Identifier, of the transmitting Bridge
  4. Port Identifier, of the Port through which the message was transmitted
  5. Port Identifier, of the Port through which the message was received (where relevant)

Info derived from IEEE Standard 802.1D - 2004, Media Access Control (MAC) Bridges, section 17.5 Spanning tree priority vectors

Since Gi0/23 is connected to a FastEthernet port, it inherently has a lower speed (resulting in a higher cost).

     Interface           Role Sts Cost      Prio.Nbr Type
     Gi0/23              Altn BLK 19        128.23   P2p
     Gi0/24              Root FWD 4         128.24   P2p
                                  ^^^

If you want to load balance across these links with STP, you would also need to add the following configurations:

interface GigabitEthernet0/24
 spanning-tree vlan 70,80,90,100,150 cost 4
interface GigabitEthernet0/23
 spanning-tree vlan 10,20,30,40,50,60 cost 4
2
  • Just to be clear, the question is under the second code block and reads "is this a right configuration??" You got the gist of it, but I figured I would point that out.
    – YLearn
    Jun 9 '15 at 18:24
  • 1
    Or use MSTP, which is designed for this sort of thing.
    – Ricky
    Jun 9 '15 at 20:25
-9

The configuration is outdated because STP Is outdated, replaced by 802.1q-2014(.aq Shortest Path Bridging, SPB).

* Don't Deploy STP
MLAG Multi-Chassis Link Aggregation Groups
    VSS
    Cross-Stack Etherchannel
    FabricPath (uses IS-IS at layer 2)
    VPC (Virtual Port Channel)
    Brocade’s VCS (Virtual Cluster Switching)
IETF TRILL (Transparent Interconnection of Lots of Links)
IEEE 802.1aq (Shortest Path Bridging – SPB)

12
  • 4
    Are you sure that all the switches are able to run such a new protocol? Jun 9 '15 at 16:34
  • to be honest sir, im new on cisco switches thats why i signup to this site for learning also. the switches i have here WS-C3560-24TS-S V02 IOS VER: 12.2(25)SEE2 and WS-C2960-L V02 IOS VER: 12.2(25)FX. My apology to all if i have not arrange my question. thank you.. Jun 10 '15 at 1:47
  • wikipedia "shortest path bridging, the IEEE sanctioned replacement for these spanning tree functions." Jun 10 '15 at 1:55
  • 2
    Don't listen to his rantings. STP is what you have to work with. "SPB" is not supported on the 3560 or 2960, and likely never will.
    – Ricky
    Jun 10 '15 at 21:14
  • 1
    Because that's how you come across. Did you even read the links you provided? Why Spanning Tree is Evil -- "Spanning Tree is not inherently bad or wrong, but it does have many limitations in its design and operation." You routinely provided misinformation with little or no research. Here, Cisco doesn't do SPB.; the hardware he's using doesn't do SPB. Your answer is about as useful as a history of the Spanish Inquisition -- completely irrelevant to the question asked.
    – Ricky
    Jun 11 '15 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.