3

I hope can someone help me with my problem on my Cisco 2960 switch.

My question is this: when I configure the Gig0/1 port on my client 2960 switch as trunk, and connect it to my server 3560 switch on port Gig0/24 with switchport trunk encapsulation dot1q and switchport mode trunk, there is no connection running on either port, and when I check the status of the of my 2960 port, this is what I get:

GigabitEthernet0/1 is down, line protocol is down (notconnect)
Hardware is Gigabit Ethernet, address is 0018.18da.8b81 (bia 0018.18da.8b81)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
 reliability 255/255, txload 1/255## Heading ##, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
 0 packets input, 0 bytes, 0 no buffer
 Received 0 broadcasts (0 multicast)
 0 runts, 0 giants, 0 throttles

When I connect Gig0/24 to another port on my 2960, for example port gig0/2, and configure it as trunk, it status connected, and there is a connection.

Is this a bad port?

7
  • 3
    Double check the connection, do you have lights? Bad cable? I would say it is a "Layer 1" problem.
    – mrlayance
    Commented Jun 11, 2015 at 16:24
  • 7
    Please attach the port configuration for both gig0/1 and gig0/2. Double check wiring, patch panel connections, etc.
    – HAL
    Commented Jun 11, 2015 at 16:27
  • in a default, powering the cisco 2960 the LED light on port gig0/1, but after that when i connect cable it doesnt light. no matter what i do on configuring the port still no connection. i also clean the port, maybe some dust but stil no work. all the port on 3560 and 2960 are all running except to that port gig0/1 on 2960. theres no error. i use a new cable but doesnt work also. i suspek a terminal lost connection to that port. hardware. Commented Jun 12, 2015 at 3:48
  • 2
    Had you check the cable before??. Try to change the MDI-X configuration on the ports. Commented May 2, 2016 at 19:27
  • 1
    I agree, it is likely a layer 1 issue. You can verify if it is a bad port by configuring it as an access port and testing.
    – AJ Acevedo
    Commented Nov 29, 2016 at 5:30

3 Answers 3

0

just a couple of extra thoughts i think may help.

-check for port-security issues

-if it is indeed a faulty port, you could try guiding the cable in an upwards direction (helped me on more than 1 occasion)reference picture cabling

0

Cisco switch catalyst 2960 is layer2 switch . The command you used is not compatible with layer2 switch for Configuring trunk port .

Gig0/24 with switchport trunk encapsulation dot1q and switchport mode trunk

Instead of above command , use below command

Switch(config)#int Gig0/24

Switch(config)#switchport mode trunk

Switch(config)#switchport trunk allowed vlan all

Switch(config)#no shutdown

-1

Sound's like a layer 1 problem as pointed out by mrlayance.

Taking into consideration one of the switchports isn't faulty, try a Cat5E or Cat6 cross-over cable between the two switches. Then try these commands on the trunk interfaces:

conf t
int gi0/x
shut
no mdix auto
speed 1000
duplex full
switchport nonegotiate
no shut

These links should assist you further:

https://learningnetwork.cisco.com/thread/21541

https://cciepursuit.wordpress.com/2007/07/08/switch-cabling-and-auto-mdix/

2
  • 2
    Deactivating auto negotiation potentially leads to a duplex mismatch (which is very ugly) and (as per standard) disables gigabit and faster rates.
    – Zac67
    Commented Jun 27, 2017 at 9:59
  • Agreed. Never disable auto negotiation and/or auto speed and duplex on modern network equipment unless you have absolutely no other choice and then only temporarily while you figure out the real cause of the problem. Commented Nov 16, 2022 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.