1

I have configured ACL for NAT and PFR purpose. ios c1841-adventerprisek9-mz.151-4.M4.bin

 ip access-list extended PFR
 permit ip 192.168.0.0 0.0.7.255 any log

route-map isp2 permit 10
 match ip address PFR
 match interface Serial0/0/0
!
route-map isp1 permit 10
 match ip address PFR
 match interface FastEthernet0/0
!

ip nat inside source route-map isp1 interface FastEthernet0/0 overload oer
ip nat inside source route-map isp2 interface Serial0/0/0 overload oer

Where 192.168.1.0 255.255.248.0 inside network(fa0/1), 213.70.2.0 fa0/0 - outside, 80.4.5.0 s0/0/0 - outside.

FastEthernet0/0            213.70.2.2      
FastEthernet0/1            192.168.1.1    
Serial0/0/0                80.4.5.2 

But local addresses are not matched. Also I tried to rewrite it by how it was told in Cisco manual "Performance Routing Configuration Guide, Cisco IOS Release 15M&T", but :

 office(config)#ip nat inside source route-map PFR1 pool isp1 oer
                                                                  ^
    % Invalid input detected at '^' marker.

Both oer and pfr options are unavailable.

here is the new config:

ip nat pool isp1 213.70.2.2 213.70.2.2 prefix-length 30
ip nat pool isp2 80.4.5.2 80.4.5.2 prefix-length 30

access-list 1 permit 192.168.0.0 0.0.255.255 log

route-map PFR1 permit 10
 match ip address 1
 match interface FastEthernet0/0
!
route-map PFR2 permit 10
 match ip address 1
 match interface Serial0/0/0
!

If I write overload oer, the command is accepted. What is wrong with config and why my ios doesn't have option as it was written ?

PS. The funniest thing is that it had worked before I had a business trip

Pro Inside global      Inside local       Outside local      Outside global
icmp 213.70.2.2:1      192.168.1.3:1      192.168.176.63:1   192.168.176.63:1
office#wr 

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.