2

I have two switchs cisco 2960 (sw-120 and IDF1-SW) and router cisco 1841 (IDF1-R).

fa0/24 at sw-120 connected via fa0/7 at IDF1-SW

fa0/7 and fa0/24 at IDF1-SW switched to trunk mode

fa0/24 at sw-120 switched to trunk mode too

fa0/1 at sw-120 switched to access to vlan 120

Router(IDF1-R) configured to accept traffic from vlan 120 by subinterface fa0/1.120

IDF1-R(config-subif)#encapsulation dot1q 120
IDF1-R(config-subif)#ip ad 10.6.1.26 255.255.255.252

Laptop3 configuration is

IP : 10.6.1.25   
Subnetmask : 255.255.255.252
Gateway : 10.6.1.26

Problem : I can not ping gateway(10.6.1.26) from Laptop

enter image description here

enter image description here

Update

sw-120#show spanning-tree vlan 120
VLAN0120
  Spanning tree enabled protocol ieee
  Root ID    Priority    32888
             Address     0007.EC16.0917
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32888  (priority 32768 sys-id-ext 120)
             Address     0007.EC16.0917
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/24           Desg FWD 19        128.24   P2p

sw-120#

Update 2.

Here is IDF1-SW running config IDF1-SW#sh ru Building configuration...

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname IDF1-SW
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
 switchport access vlan 120
 switchport mode trunk
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Here is sw-120 running config

sw-120>en
sw-120#sh ru
Building configuration...

Current configuration : 1430 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname sw-120
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 120
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 119
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 118
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 117
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 116
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 114
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 113
 switchport mode access
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
  • 1
    on sw-120, type show spanning-tree vlan 120, and post the result – Ron Trunk Jun 23 '15 at 0:46
  • @RonTrunk, Please look at the updated topic – Serg Jun 23 '15 at 5:05
  • In your question you have written fa0/1 and fa0/24 at IDF1-SW switched to trunk mode - Did you mean fa0/7 instead of fa0/1 ? Also can you show the configuration of each port? – jwbensley Jun 23 '15 at 8:31
  • @jwbensley, Sorry it's my fall. Yes I mean fa0/7. Yes, sure I can, please look at the updated topic – Serg Jun 23 '15 at 8:45
  • According to the show spanning-tree command, your switch is not forwarding packets out of port Fa0/1. Since your switch is configured correctly, that suggests there's a physical connection problem. Recheck your physical connection. Also type "show int fa 0/1" and post that output. – Ron Trunk Jun 23 '15 at 11:35
1

Solved. The solution is VTP domains. You should create VTP domains. IDF1-SW should be in mode vtp-server and sw-120 in mode vtp-client

| improve this answer | |
  • Remember to flag this as solved. – Jan Jun 23 '15 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.