2

I have 4 IDFs(cisco 3560) and one MDF(cisco 3560). IDFs are connected via fa0/24 to MDF. Every fa0/24 is in mode trunk.

Look at the picture

enter image description here

Fa0/1-4 on MDF is in mode trunk.

Problem : I cannot ping any IDF from any other.

But if I set IP for their from same network -- it works.

What should I confugure to correct routing ?

Update.

Here is cite from config IDF4

hostname IDF4
!
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 no switchport
 ip address 10.6.64.1 255.255.224.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.6.0.0 255.255.224.0 FastEthernet0/24 
ip route 10.6.32.0 255.255.224.0 FastEthernet0/24 
ip route 10.6.96.0 255.255.224.0 FastEthernet0/24 
ip route 0.0.0.0 0.0.0.0 FastEthernet0/24 
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

And config of IDF5

!
hostname IDF5
!
ip routing
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 no switchport
 ip address 10.6.96.1 255.255.224.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
router rip
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/24 
ip route 10.6.0.0 255.255.224.0 FastEthernet0/24 
ip route 10.6.32.0 255.255.224.0 FastEthernet0/24 
ip route 10.6.64.0 255.255.224.0 FastEthernet0/24 
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Update 2.

MDF(config)#int range  fa0/1-4
MDF(config-if-range)#no switchport
MDF(config-if-range)#
MDF(config-if-range)#exit
MDF(config)#interface FastEthernet0/1
MDF(config-if)#no ip address
MDF(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
ip address 10.6.31.254 255.0.0.0
MDF(config-if)#ip address 10.6.31.254 255.255.224.0
MDF(config-if)#
MDF(config-if)#exit
MDF(config)#interface FastEthernet0/1
MDF(config-if)#
MDF(config-if)#exit
MDF(config)#interface FastEthernet0/2
MDF(config-if)#ip address 10.6.63.254 255.255.224.0
MDF(config-if)#
MDF(config-if)#exit
MDF(config)#interface FastEthernet0/3
MDF(config-if)#ip address 10.6.95.254 255.255.224.0
MDF(config-if)#
MDF(config-if)#exit
MDF(config)#interface FastEthernet0/4
MDF(config-if)#ip address 10.6.128.126 255.255.224.0
MDF(config-if)#

And after add route

IDF1(config)#ip route 10.6.32.0 255.255.224.0 fa0/24

And

IDF23(config)#ip route 10.6.0.0 255.255.224.0 fa0/24
IDF23(config)#end
IDF23#
%SYS-5-CONFIG_I: Configured from console by console

IDF23#
IDF23#
IDF23#ping 10.6.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.6.0.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
5
  • Did you configure any routing? – David Houde Jun 23 '15 at 19:16
  • @DavidHoude, No, I don't. What I have to do for it ? – Serg Jun 23 '15 at 19:18
  • 1
    I'm sorry man but this isn't a place for homework or basic networking questions. If you are having a specific problem, please let us know. There are many places to learn the difference between routing and switching online, this isn't the place for general training. Literally ANY routing will work here, you just need to choose something. Googling "Cisco Static Route" might give you everything you need to know. If you want to go to the chat, we might be able to talk. – David Houde Jun 23 '15 at 19:31
  • 1
    @DavidHoude, Thank you, "Cisco Static Route" helped me. – Serg Jun 23 '15 at 19:41
  • @DavidHoude, Something strange going on. Routing works only between IDF1 and IDF2 and does not works between other IDF4 and IDF5. Please look at the updated topic. – Serg Jun 23 '15 at 20:19
2

You made one network on layer 2, but put each switch in a different layer 3 network, so your MDF is a switch and it should be a router with the IP addresses you configured.

The solution is to make each port towards an IDF a routed port on the MDF, and thus giving the MDF an IP address in each network, or have the MDF configured as a switch and put all IDF's in the same network.

3
  • I gave MDF ip in each network, but I still cant ping any of IDFs. – Serg Jun 23 '15 at 22:17
  • Please look at the updated topic – Serg Jun 23 '15 at 22:21
  • please show the actual configuration of the MDF, not just the changes. Also, please provide a 'show ip route' output of the MDF and two IDF's which can't reach eachother. – Teun Vink Jun 24 '15 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.