1

I need to be able to ping a DMZ host from an INSIDE host and visa versa. I have tried configuring a static nat as follows

static (INSIDE,DMZ) 192.168.10.0 192.168.10.0 netmask 255.255.255.0

I created an access-list called EXEMPT which permits any any. I know this is not the most secure option but at this point I just need it to work.

Any help and insight into this would be amazing.

Here is the config of my device.

!
interface Vlan1
 no nameif
 no security-level
 no ip address
!
interface Vlan3002
 nameif OUTSIDE
 security-level 0
 ip address 157.201.226.6 255.255.255.252 
!
interface Vlan3022
 nameif INSIDE
 security-level 50
 ip address 192.168.10.1 255.255.255.0 
!
interface Vlan3052
 nameif DMZ   
 security-level 50
 ip address 192.168.50.1 255.255.255.0 
!
interface Ethernet0/0
 shutdown
!
interface Ethernet0/1
 switchport access vlan 3022
!
interface Ethernet0/2
 shutdown
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!             
interface Ethernet0/7
 switchport trunk allowed vlan 3002,3022,3052
 switchport mode trunk
!
ftp mode passive
dns domain-lookup OUTSIDE
dns domain-lookup INSIDE
dns domain-lookup DMZ
same-security-traffic permit intra-interface
access-list OUTSIDE_access_in extended permit ip any any 
access-list INSIDE extended permit ip any any 
access-list OUTSIDE extended permit tcp any any eq 3389 
access-list OUTSIDE extended permit udp any any eq 3389 
access-list OUTSIDE extended permit tcp any any eq www 
access-list OUTSIDE extended permit udp any any eq www 
access-list OUTSIDE extended permit tcp any any eq https 
access-list OUTSIDE extended permit udp any any eq 443 
access-list OUTSIDE extended permit tcp any any eq ssh 
access-list OUTSIDE extended permit udp any any eq 22 
access-list OUTSIDE extended permit tcp any any eq 1 
access-list OUTSIDE extended permit udp any any eq 1 
access-list OUTSIDE extended permit icmp any any 
access-list OUTSIDE extended permit tcp any any eq 50 
access-list OUTSIDE extended permit tcp any any eq 51 
access-list OUTSIDE extended permit udp any any eq isakmp 
access-list OUTSIDE extended permit tcp any any eq ftp 
access-list DMZ extended permit ip any any 
access-list INSIDE_access_in extended permit ip any any 
access-list from-dmz extended permit ip any any 
access-list DMZ_access_in extended permit ip any any 
access-list dmz-acl extended permit ip any any 
access-list EXEMPT extended permit ip any any 
access-list DMZ_nat0_outbound_1 extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu OUTSIDE 1500
mtu INSIDE 1500
mtu DMZ 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-647.bin
no asdm history enable
arp timeout 14400
global (OUTSIDE) 1 interface
nat (INSIDE) 1 0.0.0.0 0.0.0.0
static (DMZ,OUTSIDE) 157.201.226.72 192.168.50.2 netmask 255.255.255.255 
static (DMZ,OUTSIDE) 157.201.226.73 192.168.50.3 netmask 255.255.255.255 
static (DMZ,OUTSIDE) 157.201.226.75 192.168.50.5 netmask 255.255.255.255 
static (INSIDE,OUTSIDE) 157.201.226.74 192.168.10.74 netmask 255.255.255.255 
static (INSIDE,DMZ) 192.168.10.0 192.168.10.0 netmask 255.255.255.0 dns 
access-group OUTSIDE in interface OUTSIDE
access-group EXEMPT in interface INSIDE
access-group EXEMPT in interface DMZ
access-group EXEMPT out interface DMZ
route OUTSIDE 0.0.0.0 0.0.0.0 157.201.226.5 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server Duo-Radius protocol radius
aaa-server Duo-Radius (DMZ) host 192.168.50.4
 timeout 20
 key cuddlypuppies
 authentication-port 1812
 accounting-port 1813
 no mschapv2-capable
aaa authentication ssh console LOCAL 
http server enable
http 0.0.0.0 0.0.0.0 OUTSIDE
snmp-server host DMZ 192.168.50.5 community public
no snmp-server location
no snmp-server contact
snmp-server community *****
snmp-server enable traps snmp authentication linkup linkdown coldstart
no sysopt connection permit-vpn
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map OUTSIDE_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map OUTSIDE_map interface OUTSIDE
crypto map INSIDE_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map INSIDE_map interface INSIDE
crypto map DMZ_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map DMZ_map interface DMZ
crypto isakmp enable OUTSIDE
crypto isakmp enable INSIDE
crypto isakmp enable DMZ
crypto isakmp policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.255.255.255 OUTSIDE
ssh 10.0.0.0 255.0.0.0 OUTSIDE
ssh 0.0.0.0 0.0.0.0 OUTSIDE
ssh timeout 30
console timeout 0
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tftp-server INSIDE 192.168.10.2 asdm-647.bin
webvpn
 anyconnect-essentials
group-policy DfltGrpPolicy attributes
 dns-server value 8.8.8.8
 vpn-tunnel-protocol IPSec l2tp-ipsec 
username team1 password 6cSlCtoGgNx3QZLp encrypted
tunnel-group DefaultRAGroup general-attributes
 authentication-server-group Duo-Radius
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
tunnel-group DefaultWEBVPNGroup general-attributes
 authentication-server-group Duo-Radius
 authentication-server-group (DMZ) Duo-Radius
 secondary-authentication-server-group Duo-Radius use-primary-username
 authorization-server-group Duo-Radius
 accounting-server-group Duo-Radius
tunnel-group DefaultWEBVPNGroup ipsec-attributes
 pre-shared-key *
!
!
prompt hostname context 
Cryptochecksum:15266ece8259e82ee10eca7f9e72a029
: end
2
  • 2
    Can you paste the output of "show run service-policy" and "show run policy-map"? (And I hope you don't mind, I edited the formatting of your config output.) Jun 25 '15 at 1:58
  • 2
    Oh, and the output of "packet-tracer input INSIDE icmp <INSIDE-ip> 8 0 <DMZ-ip>", where the <> is replaced with your relevant IP addresses? Jun 25 '15 at 2:04
-1

Try this

access-list DMZ_nat0_outbound extended permit ip any 192.168.10.0 255.255.255.0 

nat (DMZ) 0 access-list DMZ_nat0_outbound
0
1

Traffic between two interfaces of the same security level is dropped. This is the innate behavior of the ASA.

It can be overridden by applying this command: same-security-traffic permit inter-interface

Not to be confused with "same-security-traffic permit intra-interface". Which allows traffic to flow in and back out the same interface. I saw you had this one applied, and you might actually need it. But you will definitely need to apply the other one as well (inter).

Better yet, you could also change the Inside's security level to 100 (or really any value more than that of your DMZ, which is currently 50). If I were you, that is what I would do. Since you have them separated, you may as well consider one more secure than the other.


Additionally, you will want to apply NAT Exemption properly. Trying to do it with this catch all Static NAT will work... until you want traffic to flow from the Inside to the Outside interface.

static (INSIDE,DMZ) 192.168.10.0 192.168.10.0 netmask 255.255.255.0 dns 

Remove this static statement. And apply NAT Exemption in a way where it will ONLY apply to traffic between the Inside and DMZ interface. Which means you have to do a Policy NAT Exemption (aka, NAT Exemption with an ACL). It will look like this:

access-list NONAT permit ip 192.168.10.0 255.255.255.0 192.168.50.0 255.255.255.0
nat (inside) 0 access-list NONAT

This way, when your Inside hosts are speaking to the Internet, it won't match the NAT Exemption and will be processed via your regular Static statements. But when your Inside hosts are trying to speak to your DMZ hosts, the NAT Exemption will take precedence over your Static statement, and let the traffic proceed without the need for NAT.

A further note: NAT Exemption is bi-directional innately, so you do not need to apply an ACL entry for traffic in the other direction. *So long as you apply the ACL from the perspective of traffic initiated from the higher security level, as above.

3
  • I tried your preferred suggestion after removing the static NAT statement and it didn't work. I think I may have a conflicting setting. I'm going to try and clean up some config and try again.
    – VERNSTOKED
    Jun 26 '15 at 2:28
  • @Vernstoked did you add this command? same-security-traffic permit inter-interface
    – Eddie
    Jun 26 '15 at 2:43
  • I changed the security-level of the INSIDE to 100. That means the DMZ is 50 and the INSIDE is 100. I shouldn't need that command with that configuration should I? Or is it still required?
    – VERNSTOKED
    Jun 27 '15 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.