I've very green with cisco devices so I apologize upfront should this be a 'silly' question.

I've setup a cisco 2504 wireless controller (WLC) and enabled the DHCP server feature so I could distribute IPs to any devices connected to it. The WLC is not connected to a WAN; only LAN devices are connected.

When I connect my computer to the WLC to configure it, I am able to access it through the web interface and send ping packets. When I then connect a cisco AP to the WLC, both the AP and the computer fail to communicate with the WLC. Basically, only 1 device can be connected to the WLC at any given time.

Can anyone help me get to the bottom of this please ?

Regards and thanks in advance, J

  • The AP needs an IP address in order to talk to the WLC. You have to use an external DHCP server on the wired LAN or statically configure the AP. It sounds like you might have an IP conflict?
    – Ron Trunk
    Commented Jun 25, 2015 at 11:50
  • Thanks for your reply @RonTrunk. I tried to configure a Gigabit interface interface(Gi1) with a static IP, however it seems that since the AP operates on a lightweight (firmware rather than a Autonomous one), I couldn't get to configure a static IP on physical interface. What syntax would I need to use on a lightweight AP to configure a static IP please ?Thanks in advance, J Commented Jun 25, 2015 at 11:58
  • Try lwapp ap ip address x.x.x.x. (I've never tried this. It may not work on newer APs)
    – Ron Trunk
    Commented Jun 25, 2015 at 12:15
  • the information contained in this question & answer might help Commented Jun 25, 2015 at 12:37
  • @RonTrunk When I configure the LWAPP IP I am getting the error You should configure Domain and Name Server from controller CLI/GUI. Commented Jun 25, 2015 at 12:45

1 Answer 1


For anyone unable to connect a cisco access point in lightweight mode to the Wireless controller, this did the trick for me:

Step 1
Follow these steps to disable the 802.11a and 802.11b/g networks as follows: a. Choose Wireless> 802.11a/n > Network. b. Unselect the 802.11a Network Status check box. c.
Click Apply to commit your changes. d. Choose Wireless > 802.11b/g/n > Network. e. Unselect the 802.11b/g Network Status check box. f. Click Apply to commit your changes.

Step 2
Choose Wireless > Country to open the Country page

Step 3
Select the check box for each country where your access points are installed. If you selected more than one check box, a message appears indicating that RRM channels and power levels are limited to common channels and power levels.

Step 4
Click OK to continue or Cancel to cancel the operation.

Step 5
Click Apply to commit your changes.

Step 6
Reenable the 802.11a and 802.11b/g networks

See more at: https://supportforums.cisco.com/discussion/11420901/issue-connecting-1131ag-regulatory-domain-check-has-failed-ap#sthash.riTr9kdw.dpuf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.