4

At one of our offices, a new ISP recently installed an Internet connection via Radwin microwave radios, going to an E1 line back to the capital where their routing equipment is. There is a very strange problem which has prevented us from using the Internet connection, and neither our technicians nor the ISP's have been able to resolve it.

When a laptop computer is connected to the Radwin, it can use the Internet connection. However, when we go from Radwin to our router (Linux-based) through a switch (HP 3500-24G-PoE+ yl), the connection is not usable. Our router ARPs for the GW, but never receives any replies.

Using mirror and monitor commands to mirror traffic from various switchports to another switchport where a laptop is running Wireshark, I can see ARP replies from the ISP reaching the ingress switchport. But the ARP replies are not visible on the egress switchport (to the router).

In Wireshark, I can see that the destination MAC addresses on these ARP packets is the router's address. I can also see the router's address in the switch's MAC address table. The switch should forward those packets to the egress switchport! But it doesn't.

Both switchports are on the same VLAN (ingress is untagged, egress is tagged). We are not using anything like arp-protect. No lockout-mac, no dhcp-snooping, no spanning-tree. The config is almost minimal.

The obvious conclusion is that the switch itself could be defective. But I have tried another HP switch and a Cisco SF302, with the same results in each case. I have also tried updating the firmware in the original HP 3500. All 3 of these switches have been successfully used elsewhere. Everything on our LAN works through any one of them. And the secondary Internet connection which is being used right now works through them as well, just not the new primary connection.

Also interesting is that I can ARP-ping (and ICMP ping) the management interfaces on the Radwins, from the router, through the switch. Those ARP replies pass through the switch just fine. But the ones from the GW do not.

I have experimented with manually setting MDIX, port speed, and duplex settings on the relevant switch ports; no difference.

Also interesting: the GW's MAC address does not appear in the switch's MAC address table. The MAC addresses of the Radwins and the router do.

Do you have any ideas why on earth these switches would behave this way???

  • 2
    You mentioned that you've tested: A) laptop directly connected to Radwin, B) Linux router via switch to Radwin. Please consider testing: C) Linux router directly connected to Radwin, D) Another router (maybe a cisco?) via switch to Radwin, E) Another router directly connected to Radwin (if it won't work through the switch). – Mike Pennington Jun 26 '15 at 10:46
  • The HP switch appears to be Layer 3. Have you disabled ip routing on the switch for your troubleshooting? – user4565 Jun 27 '15 at 23:41
  • @user4565, we never enabled IP routing on the HP switch, and show running-config doesn't show any related configuration. Do you need to explicitly disable the layer 3 functionality? – Alex D Jun 30 '15 at 12:17
  • @MikePennington, we tried a 2nd router, of the same type as the 1st, through the switch. No go. We don't own any Cisco routers, unfortunately. – Alex D Jun 30 '15 at 12:18
  • @AlexD - Quite unsure what the Radwin switchport is configured as and whether you have access to it.. Try plugging a laptop directly into the Radwin and running a wireshark session to capture what it's sending to the laptop. Have you also tried using a cross-over cable between the Radwin and the switch? Also could you please post the HP switch config. – user4565 Jun 30 '15 at 19:53
2

What does the switch port configuration look like? Access, trunk, something else? Have you asked your ISP what their port configuration (not on the Radwin, but on their router/switchport facing you) looks like? Is spanning-tree forwarding facing the Radwin link in both directions? It kind of sounds like a VLAN mismatch or something along those lines.

Does it work if you plug that laptop into the switch? That would likely rule out the router config.

  • The ingress port is untagged VLAN 256 (access), the egress port is tagged 256 (trunk). The question states that spanning-tree is not enabled, so "no" to that one. The ISP doesn't know the port configuration on the switch/router facing us, because it's not theirs -- they are paying another company for transport of packets between the city where they are located and the city where our office is located. The technology the 3rd party (a telco) is using is an "E1 line" -- I've never worked directly with this technology and don't know anything about it. – Alex D Jun 30 '15 at 12:13
  • I understand that from our ISP's point of view, the 3rd party's equipment is "transparent". It just shuffles frames back and forth. (So our default gateway is actually hundreds of KM away, in a different city.) The ISP can't otherwise interact with it in any way, but must deal with the 3rd party if there is anything wrong with it. – Alex D Jun 30 '15 at 12:20
  • Thanks for the suggestion to try laptop through switch - it doesn't work. – Alex D Jun 30 '15 at 12:21
  • If the egress port is tagged, your laptop likely wouldn't work, since it won't know what to do with the VLAN tag (unless you've specifically turned it on in the driver), and when the laptop SENDS traffic, that traffic wouldn't be tagged either, and would either be dropped, or assumed to be part of the native VLAN on the port (usually VLAN 1). – Timbo Jones Jun 30 '15 at 16:46
  • Is your router set to tag traffic destined for the Radwin? If not, it's facing the same issue as the laptop. You might try either setting the router to tag traffic, or test setting the egress port on your switch to an access port as well. Can you send us the port configs for your router, as well as both switchports? – Timbo Jones Jun 30 '15 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.