2

I'm new in the IPv6 Topic and Yesterday I was performing some testing on Cisco IOS and Cisco Routers of the addressing type in IPv6 with RIPng, i was testing the following:

  • Global Unicast Address
  • Link-Local Address
  • Anycast Address
  • Unique Local Address (which I have a confusion also, but I will post it in other time occasion and question)

Here is a picture of my network topology

IPv6 Testing Topology

The testing occurs in Cisco Packet Tracer 6.2 version.

Objective: What I want to achieve is to use the Anycast Address to 2 DNS server on the Network, 1 on under R1 LAN and 2 under R2 LAN and the rest of the LAN use the Global Unicast for their respective networks and allow end devices to keep sending request to the DNS's if any of them fails.

For some reason that I still don't understand is that the Router pick up the Anycast address for the Internal LAN, instead of the Global Unicast Address when I do Stateless Auto configuration on the host or end devices.

During my research I watch the following YouTube video IPv6-07 Cisco IPv6 Anycast which is why it inspired me to do my testing on my own.

I know that by doing VLAN’s in a L3 Switch it does what I want, but let’s skip that and pretend that I have a plain LAN.

When I do Show IPv6 Interface g0/0 on R1

This is the output that I receive

 R1#show int g0/0
GigabitEthernet0/0 is up, line protocol is up (connected)
  Hardware is CN Gigabit Ethernet, address is 00d0.ff96.cd01 (bia 00d0.ff96.cd01)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is RJ45
  output flow-control is unsupported, input flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 149 bits/sec, 0 packets/sec
     3 packets input, 224 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 watchdog, 1017 multicast, 0 pause input
     0 input packets with dribble condition detected
     73 packets output, 39144 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

This is the show ipv6 interface brief and show running-config

GigabitEthernet0/0         [up/up]
    FE80::1
    2001:DB8:22::1
    2345::
GigabitEthernet0/1         [administratively down/down]
GigabitEthernet0/2         [administratively down/down]
Serial0/0/0                [up/up]
    FE80::1
    2001:DB8:1::1
Serial0/0/1                [administratively down/down]
Serial0/1/0                [administratively down/down]
Serial0/1/1                [administratively down/down]
Vlan1                      [administratively down/down]

Show run

R1#show run 
Building configuration...

Current configuration : 1287 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
ipv6 dhcp pool R1
 dns-server 2345::9
!
!
!
license udi pid CISCO2911/K9 sn FTX1524RD6F
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:22::/64 eui-64
 ipv6 address 2345::/64 anycast
 ipv6 nd other-config-flag
 ipv6 rip RIP1 enable 
 ipv6 dhcp server R1
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:1::1/64
 ipv6 rip RIP1 enable 
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router rip RIP1
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

P.S:I need Clarification with Link-Local Address, Why i can put the link local on the same device in all it interface many times? It confuse me since R2 have and other link-local address that i can also put on all it interfaces

2
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 11, 2017 at 18:29
  • I completely forget it! wow i drop that lab, i will someday take do it again.
    – Ran Shemer
    Apr 5, 2018 at 2:12

1 Answer 1

3

There are two different types of anycast. The most common one is where you have multiple routes for the same prefix going to different locations. The routing protocol will choose the best router and the traffic end up at the closest server. One way to do this is to let the DNS servers participate in the routing protocol (RIP in this case) and give them a separate prefix, for example 2001:db8:dddd::/64. Both DNS servers run their own RIP daemon to advertise that prefix. The DNS service is run on i.e. 2001:db8:dddd::1. If a DNS server falls the route it advertised will disappear and the routing protocol will route the traffic to the other DNS server. This works for both IPv4 and IPv6.

IPv6 has a second type of anycast: anycast addresses. They are normal address but configured in such a way that you can have one address on the same LAN configuredon multiple devices. So you can have two DNS servers connected to one LAN with the same addres.

7
  • I am unfamiliar with the 2nd way you describe. Explain to me how two servers with the same IPv6 address can exist in the same network? Do they alternate responding to Neighbor Solicitations? If so, how do they stay in sync?
    – Eddie
    Jun 30, 2015 at 6:01
  • 1
    They both respond to ND. The fastest one wins and its MAC address gets cached by the requesting node. If it stops working NUD will notice, and a new NS and find the next fastest node. Jun 30, 2015 at 6:57
  • NA packets for anycast addresses have the Override flag set to 0 so slower responses don't override the faster response. Jun 30, 2015 at 7:05
  • How do they accept an IPv6 address after doing Duplicate Address Detection and noticing another node on the network already has the address?
    – Eddie
    Jun 30, 2015 at 13:10
  • 1
    Simple: A host doesn't do DAD for addresses configured as anycast :) Jun 30, 2015 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.