4

Other devices (MickoTik, Windows Laptop with builtin PPPoE client) seem able to connect to the NTU's PPPoE with no issue.

Sanitized router configuration:

!
! Last configuration change at 06:55:18 UTC Thu Jul 9 2015
version 15.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable secret 5 ########################
enable password ###########
!
no aaa new-model
no process cpu extended history
no process cpu autoprofile hog
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
license udi pid C891F-K9 sn ##########
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface GigabitEthernet0
 no ip address
 no cdp enable
!
interface GigabitEthernet1
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet2
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet3
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface GigabitEthernet4
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet5
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet6
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet7
 no ip address
 shutdown
 no cdp enable
!
interface GigabitEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface Vlan1
 mtu 1492
 ip address 10.10.30.247 255.255.255.0
!
interface Async3
 no ip address
 encapsulation slip
!
interface Dialer1
 mtu 1492
 ip address negotiated
 encapsulation ppp
 ip tcp adjust-mss 1436
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname ##########@###.###.###.##
 ppp chap password 0 #########
 ppp pap sent-username ##########@###.###.###.## password 0 #########
 no cdp enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
!
!
no service-routing capabilities-manager
no cdp run
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
 exec-timeout 0 0
 no modem enable
line aux 0
line 3
 modem InOut
 speed 115200
 flowcontrol hardware
line vty 0 4
 password ##########
 login
 transport input all
!
scheduler allocate 20000 1000
!
end

The GigabitEthernet interfaces are the only ones the came up as a valid option for configuring PPPoE in CCP.

Also debug pppoe events is just giving:

*Jul  9 23:56:36.089:  padi timer expired
*Jul  9 23:56:36.089:  Sending PADI: Interface = GigabitEthernet3

I'm not sure how to go forward with this to get this working.

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 11 '17 at 18:40
0

You need to do a few things here. You will need to configure a VPDN group, dialer interface, assign that dialer interface to a dialer-group, and then implement that dialer-group on your interface. Follow the guide here:

Configuring PPP over Ethernet with NAT:

Configuration Example

The following configuration example shows a portion of the configuration file for the PPPoE scenario described in this chapter.

The VLAN interface has an IP address of 192.168.1.1 with a subnet mask of 255.255.255.0. NAT is configured for inside and outside

Note Commands marked by "(default)" are generated automatically when you run the show running-config command.

vpdn enable 
vpdn-group 1 
request-dialin 
protocol pppoe 
! 
interface vlan 1 
ip address 192.168.1.1 255.255.255.0 
no ip directed-broadcast (default) 
ip nat inside 

interface FastEthernet 4 
no ip address  
no ip directed-broadcast (default) 
ip nat outside 
pppoe enable group global 
pppoe-client dial-pool-number 1 
no sh 

! 
interface dialer 1 
ip address negotiated 
ip mtu 1492 
encapsulation ppp 
ppp authentication chap 
dialer pool 1 
dialer-group 1 
! 
dialer-list 1 protocol ip permit 
ip nat inside source list 1 interface dialer 0 overload 
ip classless (default) 
ip route 10.10.25.2 255.255.255.255 dialer 0 

ip nat pool pool1 192.168.1.0 192.168.2.0 netmask 255.255.252.0 
ip nat inside source list acl1 pool pool1

!
  • (config-vpdn-req-in)#protocol pppoe ^ Results in invalid input, also that is for 87x and 85x hardware, this is 89x, they are physically quite different. – Aaron Tate Jul 10 '15 at 2:22
  • Continue your configuration without that command, it should work. – Daniel Jul 10 '15 at 4:54
  • pppoe-client dial-pool-number 1 is already set on GigabitEthernet3 – Aaron Tate Jul 12 '15 at 22:38
  • Post another or update your current sanitized running-config. It will be a lot easier to help if you do. – Daniel Jul 12 '15 at 23:15
  • It's in this config "pppoe-client dial-pool-number 1" under the interface config. for GE3 – Aaron Tate Jul 15 '15 at 5:08
0

The issue was not resolved and the device was replaced with a mikrotik.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.