2

I have been trying to diagnoise this problem for a while (slow 10Gb connection). I thought it might be firmware or settings related(MTU). How ever while looking through some SNMP stuff I discovered that the switch (Quanta LB4M) is reporting the speed as much lower then 10Gb. Why is it doing this? The switch is attached to a Dell PE2950 using a DAC. The Dell is reporting a 10Gb link, as is the switch in the port config section. Only in the SNMP am I seeing the 4.3 Gbps, and in real world testing that is where were hitting a wall, about at 550MB's. This was with raw packet generators and testing file transfer speeds with RAM disk on each system.

router config

SNMP report

Thanks, Levi

  • There could be several reasons. One or both ends (client and server) may not be capable of full 10 Gb communication, despite having 10 Gb ports, or the client(s) may not be making full 10 Gb demands on the server. The switch may not be capable of wire-speed switching, or the switch uplink may be oversubscribed. You need to do some research in order to find the root cause. – Ron Maupin Jul 15 '15 at 14:43
  • Are you using UDP or TCP to test? If you are using TCP there are MANY factors that will come in to play. My advice is to use UDP if you are only trying to measure maximum potential throughput on a link. Are you using iPerf to test? Depending on your packet generator it can actually take a quad core Nehalem generation CPU to saturate a 10Gbps link. – Daniel Jul 15 '15 at 19:07
  • I see I have a lot more to look into. I'm going to try to go directly from pc to server and retest everything with ram disk and packet generators again. I'll take more screen shots in case I have trouble. This way I can take the switch out of the question and see what the deal is with my 10gb link. Thank you guys – Levi Jul 16 '15 at 15:26
5

Little late to the website so you may have moved on but, We use Solarwinds. Under the edit node properties there is a check box for 64-bit counters. It is probably not checked. Seen the problem you've described for some non-Cisco products in Solarwinds.

Also from the manual for some manufacturers.

If the added node supports 64-bit counters and you want to use them, check Allow 64-bit counters.

Note: Orion support the use of 64-bit counters. However, these high capacity counters can exhibit erratic behavior depending on manufacturer implementation. If you notice peculiar results when using these counters, use the Node Detail View to disable the use of 64-bit counters for the device and contact the hardware manufacturer.

For some vendors we have had to submit the mibs to Solarwinds support and they compile them into the mibs database that you can download and import into Orion.

| improve this answer | |
  • This is correct. – ewwhite Aug 15 '15 at 3:21
10

Just to address the SNMP portion of your question, I'm guessing that you are seeing the 4.3Gbps result from querying the SNMP object 'ifSpeed'. If so, you are simply getting back the maximum value that is possible from a 32-bit object (i.e. 2^32-1). This is the expected behaviour for a 10Gbps interface. You will need to query 'ifHighSpeed' for the interface instead; more explanation is in RFC2863 & RFC3635.

| improve this answer | |
  • I was just using a solarwind tool, no clue what it's using but this sounds like the right answer. – Levi Jul 16 '15 at 15:28
0

In my experience issues such as this usually come down to hardware. More specifically, hard drives. You can only read/write as fast as the hard drive can perform those operations.

If the switch and the NIC are in fact capable of pushing the full 10Gb but you're capping at 4.3Gb, it may very well be server side.

| improve this answer | |
  • We used ram disk in testing as well as using raw packet generators. I can not test at the moment but I will try to find screen shots of the previous test. – Levi Jul 15 '15 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.