2

I am having trouble with configuring LACP and RSTP on a (TPLINK TL-SG3424) switch. If I reboot the VM Server or unplug one of the LACP ports it causes a RSTP topology change that pauses packet forwarding on the swtich for around ~6 seconds. (E.g I can't reach the internet from PC).

Interestingly if I unplug my PC it has no effect whatsoever on anything connected to the switch.

I am wondering what can be wrong because it seems not to be working right. I wouldn't expect to see a topology change if I unplug a LACP port.

My setup:

         ((internet))
              |
              | WAN
              | 
        (Mikrotik ROUTER)  
              | 10.10.10.1/24  (router is selected as root bridge)
              | LAN
              | Port 2
        (TL-SG3424 SWITCH) 
    Port 4 |          || LACP
           |          || Port 10,12
           |          ||
          (PC)    (VM SERVER - proxmox)
  10.10.10.2/24     10.10.10.3/24

A mikrotik router is connected to the internet via the WAN port. The LAN ports run RSTP and I have set a priority of 0 to ensure it is selected as the root bridge.

I have enabled RSTP on all the ports of the switch (TPLINK TL-SG3424). Following the TPLINK user guide, I have set the following stp security features on the switch ports:

enter image description here

Stp summary: enter image description here

The network configuration on the VM server is set to this:

auto lo
iface lo inet loopback

iface eth0 inet manual

iface eth1 inet manual

auto bond0
iface bond0 inet manual
        slaves eth0 eth1
        bond_miimon 100
        bond_mode 802.3ad

auto vmbr0
iface vmbr0 inet static
        address  10.10.10.3
        netmask  255.255.255.0
        gateway  10.10.10.1
        bridge_ports bond0
        bridge_stp off
        bridge_fd 0
  • 2
    A possible reason is that the switch doesn't think the LAG or the PC are edge ports. – Ron Trunk Jul 24 '15 at 16:46
  • Can you verify that the switch you have configured to be the root is actually being selected as root? – Todd Wilcox Jul 25 '15 at 18:01
  • @RonTrunk Yes it turned out to be this. When looking at the web page configuration, the table seems to show that the edge ports are activated, but in reality the columns are offset by one (rendered incorrectly), and they were disabled. I noticed this by finally getting a serial cable and checking the configuration from the CLI. PortFast options were disabled. Enabling portfast fixed the problem. Thank you. – krdx Jul 26 '15 at 11:08
  • Out of curiosity, why do you need RSTP? I don't see any loops in your diagram? – Cha0s Jul 26 '15 at 13:37
  • @Cha0s It's true. It's not necessary in this setup. Just experimenting.to learn how to setup STP correctly. AFAIK it's recommended to use *STP for LACP connections but I may be wrong. – krdx Jul 26 '15 at 13:55
1

It turns out the web configuration page of the tplink switch renders options incorrectly (they are offset by one column) which lead me to believe that the edge ports are activated but in reality they were not. Activating the edge ports fixed the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.