I have a Cisco 1900 Series router running and I have issued whereby clients running torrents take all the bandwidth for their own use while business users suffer the damage.

I tried setting up nbar using the config as stated below;

  ip cef
  class-map match-any LIMIT-TOR
  match protocol bittorrent
  class LIMIT-TOR
  police cir 2000000
  confirm-action drop
  exceed-action drop
  int gig 0/1
  ip nbar protocol-discovery
  service-policy input QOS-LIMIT-TOR-POLICY

Where the Interface Gigabit 0/1 is the LAN Interface on the Router.

I noticed nothing changed as I was still able to use Utorrent and I changed the policy map from what i have up there to this; policy-map QOS-LIMIT-TOR-POLICY class LIMIT-TOR exit And I an still having same issue.... I could still use Utorrent.

I did a show state on the recent configuration and got this RouterName#show policy-map int gig0/1 GigabitEthernet0/1

    Service-policy input: QOS-LIMIT-TOR-POLICY

      Class-map: LIMIT-TOR (match-any)
        9245 packets, 1103711 bytes
        5 minute offered rate 5000 bps, drop rate 5000 bps
        Match: protocol bittorrent
          9245 packets, 1103711 bytes
          5 minute rate 5000 bps
        Match: protocol gnutella
          0 packets, 0 bytes
          5 minute rate 0 bps

Class-map: class-default (match-any)
  771180 packets, 134837021 bytes
  5 minute offered rate 875000 bps, drop rate 0 bps
  Match: any 

What am I doing wrong please?

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 12, 2017 at 3:43

1 Answer 1


Thanks all. It has been rectified.

I changed the code from

  int gig 0/1
  ip nbar protocol-discovery
  service-policy input QOS-LIMIT-TOR-POLICY

to (by adding the additional line of code)

  int gig 0/1
  ip nbar protocol-discovery
  service-policy input QOS-LIMIT-TOR-POLICY
  service-policy output QOS-LIMIT-TOR-POLICY
  • and this was able2stop torrents? what model of the cisco router are u running?
    – Manny265
    Jul 28, 2015 at 9:29
  • CIsco 1900 Series... And if a torrent session is already in place while enacting this, that session wont terminate. It is best to reboot the router after the enactment.
    – Laredo
    Jul 28, 2015 at 10:18
  • I have a CCNA R&S but I have not come across this topic,what curriculum does this fall under? I have 1841s and 1941s,would it work on both? @OlanrewajuT
    – Manny265
    Jul 28, 2015 at 12:16
  • I used it in 1941 and it worked perfectly. I dont know if it would work on 1841 though.
    – Laredo
    Jul 28, 2015 at 14:02
  • @OlanrewajuT you could also just clear the connection or the NAT entry on your router (assuming you have a CBAC firewall running or NAT translations on) in order to to reset the session that is up and running after you put the service-policy on
    – knotseh
    Jul 29, 2015 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.