0

I'm pretty new at this so please forgive me if some parts of my explanation are lacking.

Thank you in advance for taking your time to read my question.

What I want to do:
Access a server from a remote terminal via an ISDN connection and windows remote access.

My (simplified) environment:
The environment consists of a remote terminal an ISDN router, a switch, and a server. The remote terminal and the ISDN router will only be used to access the server and nothing else. Changing any IP or any settings on the switch are out of the question.

[Remote Terminal]
 168.192.0.2/24
       |  
"ISDN connection"  
       |  
   [Router]  
 192.168.1.10/24  
       |
"Network segment A"  
       |  
 192.168.1.254/24   
    [L3 Switch]  
 192.168.2.254/24   
       |
"Network Segment B"  
       |
192.168.2.10/24    
    [Server]

My problem:
The switch between network segment A and B blocks all packets to and from IPs that aren't local (including the remote terminal's) so the remote terminal can't connect to the server.

My questions:
Would a 1:1 NAT rule (168.192.0.2/24=192.168.1.10/24) set on the router be a possible choice to solve my problem?

Would setting a NAT rule for the routers only internal IP have any caveats I should be aware of?

2

Yes, NAT should work just fine, however I don't think a 1:1 nat is what you want, because you're mapping to a real interface address on the router (your router may not let you do this, and if it did, traffic destined for the router may be inadvertently mapped to your remote terminal)

Source NAT (sometimes called hide NAT) would be a better solution - translating any traffic from 168.192.0.2 to 192.168.1.10, but any traffic directed to the router would be delivered correctly.

2
  • So, please correct me if I'm wrong. If I define a SNAT rule from 168.192.0.2 to 192.168.1.10 ( from ISDN connection to Network segment A) all packets will have 192.168.1.10 as their sender IP in the packet header. While a connection is established the server can talk to the Remote terminal. However, trying to open a connection to 192.168.1.10 from the server will connect to the router instead. Thank you for your answer! – plysch Jul 30 '15 at 7:39
  • Yes, that is correct. – Benjamin Dale Aug 1 '15 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.