0

This started after trying to enter password recovery mode and rebooting. It rebooted the one time and started to load the ios but had some sort of TraceBack/Exception on the screen. I reset the power to try it again and it got stuck in this state. The power and fans come on but no output to the console port. I am getting a solid orange sys light and a solid green activity light. After about 5 minutes it then reboots automatically.

I am getting no output at all on the console line, is the hardware toast? Is there a way to force a reset on the device?

No Cisco support and the warranty is up. :(

Edit: I have let it sit for a few days and came back to it. Not it turns on and just dumps this data out. The program exception just repeats itself forever until it powers off and back on again.

System Bootstrap, Version 15.0(1r)M13, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2011 by cisco Systems, Inc.
~#~#
Total memory size = 1024 MB - DIMM0 = 512 MB, DIMM1 = 512 MB

*** Program Exception ***
PC = 0x230c2b00, Vector = 0x700, SP = 0x413df4

Edit: Let it sit for a bit and restarted it and it was able to boot, but get this.

Would you like to enter the initial configuration dialog? [yes/no]: n

 17:14:13 UTC Tue Aug 25 2015: Unexpected exception to CPU: vector 700, PC = 0xFF84B840, LR = 0xFF821854

-Traceback= 0xFF84B840z 

M8500 CPU Register Context:
PC   = 0xFF84B840  MSR  = 0x00021200  CR   = 0x44022084  LR    = 0xFF821854
CTR  = 0x08A0F1A0  XER  = 0x20000000  DEAR = 0x00000000  PVR   = 0x80210030
DEC  = 0x00009F57  TBU  = 0x00000001  TBL  = 0x935E7AEB
DBCR0= 0x41000000  DBCR1= 0x00000000  DBCR2= 0x00000000
IAC1 = 0x00000000  IAC2 = 0x00000000  DAC2 = 0x00000000  DAC2  = 0x00000000
R0   = 0x00004E1F  R1   = 0x01099080  R2   = 0xEDD6B4FD  R3    = 0x00000001
R4   = 0x000000AE  R5   = 0x00000000  R6   = 0x01099138  R7    = 0x00000000
R8   = 0x00000000  R9   = 0x00004E20  R10  = 0x00000000  R11   = 0x01099080
R12  = 0x44022082  R13  = 0xB0E1D1A8  R14  = 0x05222360  R15   = 0x00000000
R16  = 0x00000000  R17  = 0x00000000  R18  = 0x00000000  R19   = 0x00000000
R20  = 0x00000000  R21  = 0x00000000  R22  = 0x00000000  R23   = 0x00000000
R24  = 0x106C0000  R25  = 0x11460000  R26  = 0x00000000  R27   = 0x11380000
R28  = 0x11380000  R29  = 0x00000002  R30  = 0x010993D0  R31   = 0x01099080File flash:crashinfo_20150825-171413-UTC Device Error :No such device
File flash0:crashinfo_20150825-171413-UTC Device Error :No such device

Writing crashinfo to flash1:crashinfo_20150825-171413-UTC
% Crashinfo may not be recovered at flash:crashinfo
% This file system device reports an error


Press RETURN to get started!

Unable to write file system sector

Jan  2 12:00:00.003: %LICENSE-2-LIC_STORAGE: Storage validation failed,  -Traceback= 0x4046BBCz 0x404768Cz 0x4028814z 0x5221F18z 0x52223CCz 0x4961FB8z 0x4965E1Cz
Jan  2 12:00:00.975: %LICENSE-2-VLS_ERROR: 'VLSsetInstallLicenseStorage' failed with an error - rc = 144 - 'Error[144]: The specified store is corrupted.',  -Traceback= 0x404752Cz 0x4028814z 0x5221F18z 0x52223CCz 0x4961FB8z 0x4965E1Cz
Jan  2 12:00:00.975: license_initialize failed with error = 26

Jan  2 12:00:00.979: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c3900 Next reboot level = ipbasek9 and License = No valid license found
Aug 25 17:12:47.583: Following corrupted license storage was un-recoverable : implicit_license:/eval_license -Traceback= 0x4046DD0z 0x4044364z 0x40449ACz 0x4961FB8z 0x4965E1Cz
Aug 25 17:12:47.587: %LICENSE-2-LIC_STORAGE

Couldn't get anywhere after that so I rebooted it and now I am back to the beginning where it won't even output anything to the console.

3

Appears there is no physical compactflash module in slot 0, appears to have on in slot 1 with at a minimum a corrupted file system and at a max bad physical flash as you are getting file system sector error and the storage areas are corrupted. Can't write the crashdump file and that is why you get the repeated reboots after 5 minutes. If control break is enabled then after the first few seconds after power on you can hit control break and dump out to the rommon prompt: May have to type flash_init to activate the file system, type set to see where it is pointing to for the ios file then type dir flash1: and see if it can read the file system. If you have access to the ios from either a backup or from another 3925 copy it to a usb stick and put in the usb flash slots if your model has them. I believe it does. I try and use 1gb sticks and smaller. Not all Cisco routers will accept the larger sticks. From the rommon prompt: type usbflash0 or 1 depending on which slot you put it in and see if the router can see the stick and the files. If so you can boot off of the usb stick. prompt: boot usbflash0:file name and hit return. If the rest of the router hardware is good then it will boot up without a config. May get a few errors go by because the rommon set is pointing to the bad flash for the config and license file but will come up if hardware is good. Best you can hope for at that point. You may be able to reformat the flash file system. If you have licensed any features when the router was purchased you will need the license file to turn on more than the base default license. Definitely either corrupted file system or bad flash.

4
  • Thanks for the reply. I will try this out, but I know I have not been able to get into rommon mode at all. I will keep trying and update my post with more info once I am done. – Jared Mackey Aug 25 '15 at 19:13
  • It depends on what the confreg is set to whether control break is enabled. If it is available at all you will see it on the console shortly after power up but it won't be there long. Depending on the pc I've had to use cntrl C to get into rommon or hit the esc key to get it to break into rommon. Depends on the Cisco product line. Good luck – bsulli Aug 25 '15 at 20:05
  • One of these solved it: Moving flash mem to another spot, using usb to change the image on the flash, kicking it very hard, restarting it 30 times to get into rommon, leaving it on for 3 hours. Seems good now, no more reboots. – Jared Mackey Aug 25 '15 at 22:12
  • Good to hear. Swift kick at a minimum makes the network admin(you) feel better! I would ftp copy(personally not a fan of tftp) everything to a backup location, especially if you have any purchased licensing files. Can't tell you how many times I've gotten out of a jam on customer networks booting to a usbflash drive. – bsulli Aug 26 '15 at 2:05
2

I don't know about the device rebooting itself after a few minutes, but ...

Baud Rate

If you're not getting any console output, try changing the baud rate. I've personally made the mistake of changing the default baud rate (line speed) from 9600 to (for example) 19200, saved, then later rebooted and forgot that I had changed it !

How you change the baud rate differs by what terminal emulator you use.
Under Windows I usually use TeraTerm or PuTTY.
For PuTTY, look under Connection -> Serial -> Speed (baud).
For TeraTerm, Setup -> Serial Port ... -> Baud rate.

Under Linux I use GNU Screen, where you can specify the speed at the command line :

screen /dev/ttyS0 115200

Looking at some documentation for your device, I see these speeds listed :

Baud rates for the USB console port are 1200, 2400, 4800, 9600, 19200, 38400, 57600, and 115200 bps.

You may need to try each. The hardware may support more speeds, too.

Alternatively, the opposite may have occurred - that both your router and terminal emulator were configured for a non-default baud rate (say 19200), but when the router restarted it defaulted to 9600 but your software's still on the old speed. Lot of possibilities.

USB vs RJ-45 serial console

According to this documentation for the 3925 : http://www.cisco.com/c/en/us/td/docs/routers/access/2900/hardware/installation/guide/Hardware_Installation_Guide/Overview.html
There are two serial ports - a USB serial console port and an RJ-45 serial console port.

If you're using one, try the other !
For the RJ-45 port, make sure that you're using the correct "Cisco rollover cable" or that if you pass the connection through a patch panel, that the wires aren't crossed-over (... an odd-number of times).

Flash

If you think that the router is passing POST and loading the ROM image fine, but is failing at loading/decompressing the full image from flash, AND if you have another 3925 and a second/spare CompactFlash card, you can try taking the flash card from the working router to see if the problem router can load the full image.
Bit of a long-shot, but you never know when troubleshooting hardware issues.
(Technically there's a small chance that using a good card in a bad router could damage the card - assess whether you'll take that risk.)

Other bad hardware

As long as your device is down and out for troubleshooting, it doesn't hurt to (safely) remove all accessory interfaces or modules. This is even a longer-shot, since I would expect console output even with failed/failing modules ... but it doesn't cost you more than a few extra minutes (as long as they're easy to remove) to try.

Good luck !

4
  • I have tried every baud rate and still not getting any output after turning it on. I have tested the cable with other devices and it is working fine. It is only this router. I have tried moving/remove memory/flash and tried all different configurations but still getting the same results. – Jared Mackey Aug 20 '15 at 16:19
  • Hmm, looks grim. One of the things that I would probably try, out of desperation, is taking compressed air/gas to clear the router of dust - especially if it's not been running in a well-ventilated area (i.e. dedicated server room). This may not be suitable for you. An amber SYSPWR light may indicate "%SYS-1-OVERTEMP: System detected OVERTEMPERATURE condition. Please resolve cooling problem immediately!" : cisco.com/c/en/us/td/docs/routers/access/2800/hardware/… Else, if the memory can be re-seated, I'd try that. – robut Aug 20 '15 at 16:43
  • I have tried re-seating the memory and tried every combination of memory and got the same result. This router has been sitting unused for quite some time and is very clean inside and the fans are working well. Has hardly been used at all I would think. – Jared Mackey Aug 20 '15 at 16:53
  • Are the PVDM's optional on this device? – Jared Mackey Aug 20 '15 at 17:09
0

Ideally you device should come up after you turn off/on the power control switch and your console window should display on going process running. You can reboot the router once again and check the console cable/connection and its setting. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.