1

Topology

Each Router is implemented with EIGRP, sharing its routes.

Works:

ISP,R1,R2,R4

Problem:

R3 can't establishment a neighbor relationship with R1 and its route can't be shared.

The same processes done with others routers I did with it.

R3 -

R3#ping 10.0.0.13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/8/22 ms

R3#sh ip protocols    
 Routing Protocol is "eigrp  1 " 
      Outgoing update filter list for all interfaces is not set 
      Incoming update filter list for all interfaces is not set 
      Default networks flagged in outgoing updates  
      Default networks accepted from incoming updates 
      EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
      EIGRP maximum hopcount 100
      EIGRP maximum metric variance 1
    Redistributing: eigrp 1
      Automatic network summarization is not in effect  
      Maximum path: 4
      Routing for Networks:  
         10.0.0.12/30
      Routing Information Sources:  
        Gateway         Distance      Last Update 
      Distance: internal 90 external 170    


R3#sh ip eigrp neighbors 
    IP-EIGRP neighbors for process 1

R1 -

R1#ping 10.0.0.14

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 19/29/49 ms

R1#sh ip protocols

Routing Protocol is "eigrp  1 " 
  Outgoing update filter list for all interfaces is not set 
  Incoming update filter list for all interfaces is not set 
  Default networks flagged in outgoing updates  
  Default networks accepted from incoming updates 
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 1
  Automatic network summarization is not in effect  
  Maximum path: 4
  Routing for Networks:  
     10.0.0.4/30
     10.0.0.0/30
     10.0.0.8/30
     1.0.0.12/30
  Routing Information Sources:  
    Gateway         Distance      Last Update 
    10.0.0.6        90            6397       
    10.0.0.10       90            8936       
    10.0.0.2        90            9818       
  Distance: internal 90 external 170

R1#sh ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.0.0.6        Se0/0/1        10   00:16:28  40     1000  0   5
1   10.0.0.10       Se0/1/1        10   00:16:26  40     1000  0   5
2   10.0.0.2        Se0/0/0        12   00:16:25  40     1000  0   5

I disabled auto-summary thought was it, but it isn't. Any suggestions?

2

Would be helpful to see EIGRP config of R1 and R3 which can be displayed with show run | section router eigrp 1 or just show run and copy the part from "router eigrp 1".

With that said I looks like you've entered the wrong network statements. On R1 you can see:

Routing for Networks:  
  10.0.0.4/30
  10.0.0.0/30
  10.0.0.8/30
  1.0.0.12/30

Should be 10.0.0.12/30 and not 1.0.0.12/30.

On R1 under router eigrp 1, you should enter network 10.0.0.12 0.0.0.3 and remove any other network statements.

The reason to remove any other network statements is because I can't see any other directly connected network than the serial links and you don't mention any loopbacks etc. The "network x.x.x.x y.y.y.y" statement tells EIGRP which interfaces it should enable EIGRP on and to advertise that network.

  • show run | section router eigrp 1 isn't avaiable on PT, Why Should I enter network 10.0.0.0 0.0.0.3 ? R1 - R3 are on the subnet 10.0.0.12. – TMoraes Aug 20 '15 at 18:15
  • 1
    @ThiagoMoraes I missread you diagram as it's a bit messy. Looks like you miss-typed the network statement for R3 with 1.0.0.12 instead of 10.0.0.12. You can issue "show run" in Packet tracer and then just copy the part of the config under "router eigrp 1" – Jimmy Aug 20 '15 at 18:22
  • Ooh God! Thanks :DD! I need to pay attention to minimum details – TMoraes Aug 20 '15 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.