0

I have 2 distinct network segments (192.168.10.0/24 & 192.168.1.0/24) in my company, and we need them bridged. The thing is the only equipment I have available is a CISCO 878 router that, unfortunately, is a bit peculiar.

The 878 is a beefed-up cousin of the consumer-grade routers ISP distribute for free. It supports routing between the (predetermined) WAN port and the 4 LAN ports, which essentially are switch ports and not router ports. It does support VLANs and configuration of the switch ports.

In my 'running-config' I have:

!
interface FastEthernet0
  switchport mode trunk
  switchport trunk encapsulation dot1q
  switchport trunk allowed all
!
interface Vlan1
  ip address 192.168.10.80 255.255.255.0
  no shutdown
!
interface Vlan2
  ip address 192.168.1.69 255.255.255.0
  no shutdown
!

Now, in my switch I have configured a port as trunk. What I want is to connect the trunk port on my switch to one of the LAN ports on the 878 and be able to route between the 2 segments.

How do I proceed from here?

UPDATE:

I understand my problem comes from the fact that the 878 has inside both a router and a switch, and the ports connecting the two are "hidden". If I had two separate devices I would simply configure subinterfaces on a a router port and proceed with router-on-a-stick configuration.

2 Answers 2

2

Just connect the trunk port on your switch to FastEthernet0 on your router which you have configured as a trunk port. Also make sure that whatever equipment you have on those two networks have configured 192.168.10.80 and 192.168.1.69 respectively as default gateways. You should also have ip routing enabled which it should be by default.

It's very much like the typical "router on a stick" except for using vlan interfaces instead of subinterfaces.

If it doesn't work, verify the trunk link with show interface status and show interfaces trunk. You can also verify the vlan interfaces with show ip int brief and make sure they are up. If they are down it's probably because you haven't created the layer 2 vlans or because they are not allowed on the trunk.

1

SVIs you created should do the job, as they are L3 interfaces and will do the routing. And using trunk with these VLANs allowed in it should enough to allow them traverse to the switch.
If this is not working, please check if the L2 VLANs are created by checking VLAN database #show vlan-switch, and you can create the VLANs in global config mode #vlan ID. The story behind this is simple - creating L3 interface will not create L2 VLAN, so you have to do it manually in order for the trunk to forward these VLANs properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.