0

I was able to connect to a remote machine using Remote Desktop application via its IP address under Windows 7.

However, I can't ping the remote machine through command line, knowing that I turned off the firewall and every other third-party application.

What should I do?

closed as unclear what you're asking by YLearn Sep 4 '15 at 6:07

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • The Windows firewall blocks ping by default. Windows 7 probably has this turned on. – Ron Maupin Sep 2 '15 at 20:39
  • Welcome to NE, we hope you will both contribute to and learn from this community. It is not clear what you are asking. Please edit your question and it will automatically start a reopen vote. You may find our Question Checklist helpful to improve your question. Some suggestions: a network diagram, configurations from network devices, why you think it is a network problem and what you have tried to do to resolve it. – YLearn Sep 4 '15 at 6:06
3

Are you sure that default GW for this machine is not discarding icmp packets? Can you still access Remote desktop? Make sure your firewall settings permit this kind of traffic on every device that stands in front of this machine.

  • I am connected to both my machine and the remote machine. I can connect to the remote machine with both Remote Desktop and TeamViewer. I turned off the firewall. I alleviated the router's firewall restriction. I don't see what I can do more? – Mohamed Ennahdi El Idrissi Sep 2 '15 at 16:35
  • Lukas is suggesting that the router or firewall connected to the remote machine might be dropping ping packets. It's somewhat common. – Jim G. Sep 2 '15 at 17:41
2

It is a good security choice to block ICMP packets on firewalls or routers, cause, this is the most simplest way to discover an entire network. You should be sure that nothing is blocking you on the way

0

I solved this by specifying the local IP address to the DMZ host (Router's firewall).

Not the answer you're looking for? Browse other questions tagged or ask your own question.