1

Does anyone have experience with creating HP and Cisco devices? I created a simple OSPF config, but I can't see any neighbours.

Here is my basic config.

#
#HP 5500-48G-PoE+-4SFP HI Switch
#
router id 30.0.0.1
#
ospf 2
 area 0.0.0.0
  network 0.0.0.0 255.255.255.255
#
interface GigabitEthernet1/0/1
 port link-mode route
 ip address 30.0.0.1 255.0.0.0
#

#
#Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)
#
interface FastEthernet0/0
 ip address 20.0.0.1 255.0.0.0
 duplex auto
 speed auto
 !
#
router ospf 2
 router-id 20.0.0.1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
#
4
  • I don't know HP that well, but on your Cisco router, if you type debug ip ospf adjacency, it will tell you why it's not forming a neighbor relationship.
    – Ron Trunk
    Sep 4, 2015 at 12:00
  • network 0.0.0.0 255.255.255.255 means no networks are included. (that's a netmask, not a wildcard)
    – Ricky
    Sep 4, 2015 at 20:37
  • @RickyBeam, the newer Cisco IOS version actually convert the mask to a wildcard mask for you for both OSPF and EIGRP. I'm not sure at what version the change was made, but it works. The Cisco code is obviously from before the change, based on the output.
    – Ron Maupin
    Sep 5, 2015 at 4:46
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 9, 2017 at 23:11

2 Answers 2

2

Bot devices must me on the same subnet if you want to communicate between then, if you have post here the configuration on the interfaces that are connected directly, i think, they cannot form adyacency.

1

I see that you have different subnets on both devices. OSPF does subnet check while forming adjacency (exception are p2p links). Make sure both devices are on the same subnet.

You can always turn on debugs to check out what is going on:

debug ip ospf hello

debug ip ospf events

debug ip ospf packet

debug ip ospf adj

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.