3

I am trying to implement simple scenario of RIP using Packet Tracer, first of all here is the scenario.

enter image description here

and I have used the following commands to configure RIPv2 in each router,

R1:

router rip
version 2
network 172.30.10.0
network 10.1.1.0
no auto-summary

R2

router rip
version 2
network 10.1.1.0
network 10.2.2.0
no auto-summary

R3

router rip
version 2
network 172.30.30.0
network 10.2.2.0

Now if i see the output of show ip route command on R1, it doesn't show any route to 172.30.0.0 subnet of R3,

     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/1/0
     172.30.0.0/24 is subnetted, 1 subnets
C       172.30.10.0 is directly connected, FastEthernet0/0

Similarly, here are the outputs of R2 and R3

R2,

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.0 is directly connected, Serial0/1/0
C       10.2.2.0 is directly connected, Serial0/1/1
     172.30.0.0/24 is subnetted, 1 subnets
R       172.30.10.0 [120/1] via 10.1.1.1, 00:00:19, Serial0/1/0

R2 only learned the path to 172.30.10.0 network on R1 but not the path of the subnetworks in R3.

R3

     10.0.0.0/24 is subnetted, 1 subnets
C       10.2.2.0 is directly connected, Serial0/1/1
     172.30.0.0/24 is subnetted, 1 subnets
C       172.30.30.0 is directly connected, FastEthernet0/0

I don't know what am I missing. I read on other post that I was supposed to disable auto-summary in each router which I have already did, and I have also clear the routing table after that but it is not working either.

  • Can you ping both R1 and R3 from R2? Do you have any form of access lists configured on the interface? (Can be shown with show ip interface <interface>) – Jimmy Sep 6 '15 at 17:37
  • I haven't configured any access-list at all – Riley Willow Sep 15 '15 at 9:25
  • 2
    You do need the no auto-summary in R3, but you also have an addressing problem on the serial link of R3. R2 thinks the network on that serial link is /30, but R3 thinks it is /24. You need to include the full configurations of those two routers so that we can track down the problem without guessing. – Ron Maupin Dec 5 '15 at 17:45
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 12 '17 at 5:47
2

You are missing no auto-summary in R3. If that does not solve the problem maybe you need to issue the 'IP routing' command in each router.

| improve this answer | |
  • Hi, I have tried that as well, but the output is still the same. – Riley Willow Sep 6 '15 at 13:03
  • may i is problem with serial links , try the Ethernet connections instead – Gadeliow Sep 6 '15 at 13:10
1

Using no auto-summary in all the three routers have solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.