I'm having trouble with what should be a simple config setting up a 10GigE SFP on an ASR-1000-x. A fiber patch is connected to the SFP sitting in the TE0 port of the device. The interface reports being up, and lower level probing of the subsystems show that the photons are flowing (i think):

router-asr1001-r0101-a#sh hw-module subslot 0/0 transceiver 0 status 
The Transceiver in slot 0 subslot 0 port 0 is enabled.
  Module temperature                        = +37.039 C
  Transceiver Tx supply voltage            = 3261.4 mVolts
  Transceiver Tx bias current              = 36000 uAmps
  Transceiver Tx power                      = -4.7 dBm
  Transceiver Rx optical power              = -3.9 dBm

this is the SFP:

router-asr1001-r0101-a#sh hw-module subslot 0/0 transceiver 0 idprom 
IDPROM for transceiver TenGigabitEthernet0/0/0:
  Description                              =  optics (type 130)
  Transceiver Type:                        = SFP+ 10GBASE-LR (274)
  Product Identifier (PID)                  = SFP-10G-LR          
  Vendor Revision                          = B 
  Serial Number (SN)                        = FNS17031564    
  Vendor Name                              = CISCO-FINISAR  
  Vendor OUI (IEEE company ID)              = 00.0B.40 (2880)
  CLEI code                                = COUIA75CAA
  Cisco part number                        = 10-2457-03
  Device State                              = Enabled.
  Date code (yy/mm/dd)                      = 15/08/11
  Connector type                            = .
  Nominal bitrate                          =  (0 Mbits/s)
  Minimum bit rate as % of nominal bit rate = not specified
  Maximum bit rate as % of nominal bit rate = not specified

Finally the interface at the upper level reports:

router-asr1001-r0101-a#show int tengig 0/0/0
TenGigabitEthernet0/0/0 is up, line protocol is up 
  Hardware is BUILT-IN-2T+6X1GE, address is 188b.9d1f.f400 (bia 188b.9d1f.f400)
  Description: Link to XO
  Internet address is
  MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  Full Duplex, 10000Mbps, link type is force-up, media type is SFP-LR
  output flow-control is on, input flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:06:11, output hang never
  Last clearing of "show interface" counters 4d01h
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 packets output, 0 bytes, 0 underruns
     156 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

The handoff has been confirmed to be 10GigE by the carrier. And they confirm that they are up and see us go down when we disconnect the fiber patch.

Trying to ping the remote end ( does not work. I suspect two things here - the output errors, and the link-type being "forced up". I also suspect this is something simple that I've overlooked in the basic setup.

Does anybody have any experiencing troubleshooting this kind of setup?

  • What fiber are you using in the entire path from your SFP to the carrier's equipment, and how long is it? 10GBASE-LR needs SMF, and, for short runs, you may need an attenuator. Are you sure the carrier's equipment giving you !0GBASE-LR and not some other standard? Your SFP must match the carrier's equipment. For example, 10GBASE-LRM would need MMF, as would 10GBASE-SR which would be limited to 26 meters, and you would need a different SFP.
    – Ron Maupin
    Commented Sep 9, 2015 at 16:21
  • I'd need to know exactly what's on the line. Connecting to carrier gear can be troublesome. (I had to "no negotiate" our gig link through AT&T because their "smartjack" -- canoga perkins -- doesn't provide any link pulses.)
    – Ricky
    Commented Sep 9, 2015 at 21:35
  • Also, is it really printing Zero. Two. ???
    – Ricky
    Commented Sep 9, 2015 at 21:35
  • ricky - naw, ip's were changed to protect the innocent. it's a slash/30 and it's XO but other than that fictionalized. Commented Sep 10, 2015 at 3:17
  • Also - as mentioned in a comment below. I don't believe there is any way for me to control negotiation on this port (TE0). Commented Sep 10, 2015 at 3:18

3 Answers 3


Problem solved: Somewhere along the troubleshooting path the SFP was removed and reinserted without rebooting the router. We tried a reboot today and the interface came up successfully. I don't know if this is a documented behavior or not, but it makes sense - try a reboot if all else fails.

  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Commented Nov 11, 2016 at 0:00

Transceiver Rx optical power = -3.9 dBm, looks to be within acceptable parameters. "show int te0/0/0 transceiver detail" will confirm if DOM is supported on the chassis. Transceiver is a SFP+ so it supports DOM.

Are you doing a long haul back to XO's location or did XO bring in something a Cisco ONS 15454 on premise to drop off a local 10g interface to you? If so then they probably used an SR on their side.

Need to confirm if XO is using an LR model on their end.

I see the link type forced-up and also see that flowcontrol for both in & out are on.

Are you hard coding everything on the port config or allowing to auto neg with the XO end? Need to find out if XO is hardcoding their end. If hard coded on your end and not theirs I would set duplex, speed to auto and turn off flow control and see if the link starts passing traffic. I doubt XO has changed default flowcontrols, speed, duplex settings on their end from the install techs I know at XO. Never know though, anything is possible.

Also as Ron mentioned. Transceivers and fiber all need to match and be correct first and foremost.

  • First of all - thanks for all the feedback. I think the suspect is currently the fiber patches. Because it is in the TenGigPort, it appears that there is nothing I can control about negotiation on the port (at least I couldn't find any documentation on that). Commented Sep 10, 2015 at 3:15

A reboot should not be the right answer, especially with that kind of network equipment. Next time you should try:

conf t
    int tengig0/0/0
        do show log
        no shut
  • You should be right, but unfortunately I wasted too much hours troubleshooting undocumented bugs with their (relatively) new platforms to refuse to reload. Now if the config and logs look fine and something funny is going on I save show tech and reload.
    – pajaja
    Commented Dec 16, 2015 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.