6

I have two Cisco 3560's in a branch office. One acts as an access switch configured with two vlans:

interface Vlan10
 ip address 192.168.0.254 255.255.255.0

interface Vlan20
 ip address 172.16.0.254 255.255.255.0

This is connected to the same model switch in a Comms room that will be routing back to the Core network. The Core for this exercise is also a 3560 layer 3 switch connected as a point to point link.

I have added the VLANs to all switches, but with different SVIs (i.e x.x.x.253/24 and x.x.x.252/24)

I have also enabled IP Routing on each switch. I would like to use OSPF to route the traffic over the network and have configured this.

I have also configured the interconnecting interfaces with 'no switchport' and assigned an IP address. These networks have been added to the OSPF routing table.

Here is a diagram with the configuration details

Interfaces on the Access switch have been configured with VLANs and the PCs are assigned static IP Addresses

Access_Switch#
interface GigabitEthernet0/1
 switchport access vlan 10
 switchport mode access
end

interface GigabitEthernet0/2
 switchport access vlan 20
 switchport mode access
end

With this information should I be able to ping a host connected to the core (or even telnet the Core switch) from a host connected to the Access switch in the branch office? Thanks in advance :)

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Jan 5, 2021 at 1:52

1 Answer 1

2

If all your interfaces are passive in OSPF, OSPF will never create neighbors.

Also, you really don't want the same network on two device separated by a layer-3 link since devices on Access VLANs 10 and 20 will never be able to communicate with Comms VlANs 10 and 20, and neither will be able to communicate with Core VLANs 10 and 20.

You really need to rethink this design.

6
  • Thanks for the quick reply. If I enter #no passive-interface G0/1 (where G0/1 is the interconnecting interfaces on all switches) will this resolve the neighbor issue? Can you please explain the issue with the VLANs separated by a layer three link? I thought that by introducing routing this would enable them to communicate at layer 3? Thanks again
    – SwitchArt
    Commented Sep 17, 2015 at 1:28
  • Right, no passive-interface <int> for the interfaces linking from one switch to the other. That doesn't solve your other problem. You can have the same VLAN numbers separated by layer-3, but they need to be separate subnets because a host in 192.168.0.0/24 on Access will never try to route to the same subnet on either of the other two switches.
    – Ron Maupin
    Commented Sep 17, 2015 at 1:33
  • Actually, Comms has to have two interfaces configured with no passive-interface <int> because it has two neighbor connections.
    – Ron Maupin
    Commented Sep 17, 2015 at 1:39
  • I wonder why you use /24 for the point-to-point links between the switches. Conventionally, most people use a /30, but you can use a /31 for point-to-point links.
    – Ron Maupin
    Commented Sep 17, 2015 at 1:41
  • Understand about the two Comms interfaces. Just kept things brief. Regarding the masks I understand that too. This is just theoretical. I am just (trying to) learn this in Packet Tracer. If I make all masks /24 I never get them mixed up (touch wood) :)
    – SwitchArt
    Commented Sep 17, 2015 at 1:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.