2

I am using GNS3 to configure the basic RIPv2 in my simple network. First of, here is my network,

enter image description here

and here is the configuration for each router,

R1,

router rip
 version 2
 passive-interface FastEthernet0/0
 network 10.0.0.0
 network 192.168.2.0
 no auto-summary


R1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1     YES manual up                    up  
Serial0/0                  10.1.1.6        YES manual up                    up  
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/1                  unassigned      YES unset  administratively down down

for R2,

router rip
 passive-interface FastEthernet0/0
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary


R2#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.2.1     YES manual up                    up
Serial0/0                  10.1.1.5        YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/1                  10.1.1.2        YES manual up                    up

R3,

router rip
 version 2
 passive-interface FastEthernet0/0
 network 10.0.0.0
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary


R3#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.2.129   YES manual up                    up  
Serial0/0                  unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Serial0/1                  10.1.1.1        YES manual up                    up 

Even though, I have configured RIPv2 in each router, my routers still wouldn't learn any routes outside its own network.

Here is the outputs of show ip route command for each router,

R1,

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.4 is directly connected, Serial0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

R2,

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.0 is directly connected, Serial0/1
C       10.1.1.4 is directly connected, Serial0/0
     192.168.2.0/25 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/0

R3,

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Serial0/1
     192.168.2.0/25 is subnetted, 1 subnets
C       192.168.2.128 is directly connected, FastEthernet0/0

When I used debug ip rip command, I see the following output,

R1,

R1#
*Mar  1 00:31:48.595: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.6)
*Mar  1 00:31:48.595: RIP: build update entries - suppressing null update
R1#
*Mar  1 00:32:15.975: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (10.1.1.6)
*Mar  1 00:32:15.975: RIP: build update entries - suppressing null update

R3,

R3#
*Mar  1 00:32:15.559: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (10.1.1.1)
*Mar  1 00:32:15.559: RIP: build update entries
*Mar  1 00:32:15.563:   192.168.2.128/25 via 0.0.0.0, metric 1, tag 0

As can be seen in the above output, both R1 and R3 are sending updates to 224.0.0.9, but I don't have any network with this ip address. Beside that, R2 is not showing any updates at all when i enabled debugging on it.

Here is the output of show ip protocols command on R2,

R2#show ip protocols
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 16 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 1, receive any version
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.1.0
    192.168.2.0
  Passive Interface(s):
    FastEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Can anyone please tell me why my routers are not learning the correct routes to neighbouring networks, and sending updates to wrong addresses ?. I have no access list or anything else configured in any of the routers, just simple RIPv2 is configured.

2
  • 5
    224.0.0.9 is the RIPv2 muticast group address. It's used to send routing information to all RIPv2-aware routers on a network segment.
    – Teun Vink
    Sep 19, 2015 at 9:05
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it.
    – Ron Maupin
    Aug 7, 2017 at 14:06

3 Answers 3

2

Make sure the routers RIP configurations are as shown below.

For R1,

router rip
 version 2
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary

For R2,

router rip
 version 2
 network 10.0.0.0
 network 192.168.2.0
 no auto-summary

and R3,

router rip
 version 2
 network 10.0.0.0
 network 192.168.2.0
 no auto-summary

The above configuration makes the Routing Protocol to work 100%.

Below are the Routes in the Routing tables of the following routers,

R1,

R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
R       10.1.1.0 [120/1] via 10.1.1.5, 00:00:05, Serial0/0/0
C       10.1.1.4 is directly connected, Serial0/0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
     192.168.2.0/25 is subnetted, 2 subnets
R       192.168.2.0 [120/1] via 10.1.1.5, 00:00:05, Serial0/0/0
R       192.168.2.128 [120/2] via 10.1.1.5, 00:00:05, Serial0/0/0

For R2,

R2#sh ip  route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.0 is directly connected, Serial0/0/1
C       10.1.1.4 is directly connected, Serial0/0/0
R    192.168.1.0/24 [120/1] via 10.1.1.6, 00:00:02, Serial0/0/0
     192.168.2.0/25 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, FastEthernet0/0
R       192.168.2.128 [120/1] via 10.1.1.1, 00:00:12, Serial0/0/1

and R3,

R3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 2 subnets
C       10.1.1.0 is directly connected, Serial0/0/0
R       10.1.1.4 [120/1] via 10.1.1.2, 00:00:11, Serial0/0/0
R    192.168.1.0/24 [120/2] via 10.1.1.2, 00:00:11, Serial0/0/0
     192.168.2.0/25 is subnetted, 2 subnets
R       192.168.2.0 [120/1] via 10.1.1.2, 00:00:11, Serial0/0/0
C       192.168.2.128 is directly connected, FastEthernet0/0

Hope this helps.

1

on R2,

network 10.0.0.0

is missing on your router rip

Since your FastEthernet Interfaces are passive, you do not need the

network 192.168.1.0
network 192.168.2.0

statements in router rip on any of your Routers. Those (still classfull) ip-nets must include the adresses on your links over RIP shall be spoken, no passive interface Serial0/0 does not suffit.

It is also save to connect s0/1 to an s0/0 Interface of an other Router. Just names.

Finally, do not spend too much time with RIP. Better learn OSPF and BGP.

0

You forgot to configure RIP version 2 for R2. You've specified it on R1 and R3, but not R2. Without this, subnet information will not be advertised and hence you cannot use disconnected networks. That's also why R2 is not showing anything on debug mode.

1
  • Hi. You should review your config cause there r some mistakes. The network that you refer to as unknown is the rip v2 multicast address for route updates.
    – Gngogh
    Jan 17, 2016 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.