1

I have a set of broadcasting devices that are using multicast.

Here is the configuration :

L3 SWITCH#
igmp-snooping
interface Vlan-interface280
 description BroadcastDevice
 ip address x.x.x.x 255.255.255.0
 pim sm
 igmp enable
 igmp version 3

interface Vlan-interface206
 description Subscribers
 ip address x.x.x.x 255.255.254.0
 igmp enable
 igmp version 3
interface Vlan-interface226
 description Not-Subscribers
 ip address x.x.x.x 255.255.254.0
 igmp enable
 igmp version 3

I am running IGMP Snooping to make sure multicast traffic is not forwarded to every port in my network. Here is a sample from my Access Switch for the relevant vlans :

L2 ACCESS SWITCH#
igmp-snooping
vlan 206
 name Subscribers
 igmp-snooping enable
 igmp-snooping version 3
vlan 226
 name Not-Subscribers

This works well. VLAN 206 users are subscribing to the source flows from VLAN 241 and VLAN 226 are not receiving anything multicast.

I wish to filter multicast on my WIFI vlans the same way I did with the VLAN 206. Here is how I tried to do it :

L3 SWITCH#
interface Vlan-interface250
 description WIFI-ADMIN
 ip address x
 igmp enable
 igmp version 3
interface Vlan-interface252
 description WIFI-SSID-CORP
 ip address x
 igmp enable
 igmp version 3
vlan 250
 igmp-snooping enable
 igmp-snooping version 3
vlan 252
 igmp-snooping enable
 igmp-snooping version 3

VLAN 250 is the vlan in which my clients are located when they authenticate on the controller. VLAN 252 is the controller VLAN.

With this configuration, my WIFI clients are still able to subscribe to multicast flows, which then brings my WiFi network down.

Anyone has any tips on what I am missing here ? Should I look in the controller configuration directly? It's a HP MSM 760.

Thank you

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 10 '17 at 3:03
2

There is an option on the controllers to enable IGMP snooping helpers that should help.

However, the issue is generally that Multicast is sent at the lowest packet rate available. Unlike an Aruba system, you can't get the controller to manage multicasts as far as I am aware.

| improve this answer | |
2

Multicast is "broadcast" traffic. It gets sent at the AP's "basic rate", which is the rate every associated client can process. This is usually less than 5.5Mbps.

Your available solutions are to block all multicast either at the switch or on the AP itself.

| improve this answer | |
  • How do you block all multicast at the AP level though ? On the switchport, I can reduce the multicast packets ratio to 1 per second, but that's not really "blocking" multicast... – Jeremy G. Sep 28 '15 at 8:55
2

If you want to shut down multicasts on an interface completely, use

storm-control multicast level 0

switchport block multicast

The first command prevents inbound multicasts from entering the switchport. The second stops outbound multicasts from getting out.

| improve this answer | |
  • 1
    Be mindful of storm-control; the typical response to a "storm" is to err-disable the port. – Ricky Beam Sep 26 '15 at 20:05
  • You have a way to just block packets and not shutdown the port. Also, I didn't specify it but the access layer switch are HP A5120 - so this command does not apply. The command "storm-constrain multicast ratio" comes to mind, but it does not answer exactly the need. – Jeremy G. Sep 28 '15 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.