3

Please HELP

Hi I am trying to configure the DHCP server in the network

The NETMAP of my network layout is

150:0/0 250:0/0
250:0/1 450:0/0
250:1/0 350:0/0
250:1/1 550:0/0`
Say here 150,250,350,450 and 550 represents the router and each interface is connected in the above fashion example the 0/0 interface of router 150 is connected to interface 0/0 of the router 250 and so on.

I am trying to make the router 450 as the DHCP server the config for that is

`!
! Last configuration change at 14:37:39 IST Tue Oct 6 2015
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
clock timezone IST 5 30
!
!
!
!
!
!
!
!
!




ip dhcp excluded-address 10.0.0.1 10.0.0.30
ip dhcp excluded-address 30.0.0.1 30.0.0.20
ip dhcp excluded-address 40.0.0.1 40.0.0.10
!
ip dhcp pool DHCP150
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1 255.255.255.0
!
ip dhcp pool DHCP350
network 30.0.0.0 255.255.255.0
default-router 30.0.0.1 255.255.255.0
!
ip dhcp pool DHCP550
network 40.0.0.0 255.255.255.0
default-router 40.0.0.1 255.255.255.0
!
!
!


ip cef
no ipv6 cef
!
!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 20.0.0.2 255.0.0.0
!
interface Ethernet0/1
no ip address
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
!
interface Ethernet1/1
no ip address
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
!
end

Can you guys please tell me what should i do on the client side ? I guess first I should provide the default routes on the client so that they know how to reach the DHCP server but even if i am trying to configure the ip routes on the client . I am getting the message as gateway of the last resort is not set whenever i do sh ip route

Also the configs on the 250 router where all the other router connects is

!
! Last configuration change at 14:44:09 IST Tue Oct 6 2015
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
clock timezone IST 5 30
!
!
!
!
!
!
!
!
!




ip dhcp excluded-address 10.0.0.1 10.0.0.30
!
ip dhcp pool DHCP1
network 10.0.0.0 255.0.0.0
default-router 10.0.0.1
dns-server 10.0.0.1
domain-name cisco.local
!
!
!
no ip domain lookup


ip cef
no ipv6 cef
!
!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 10.0.0.1 255.0.0.0
!
interface Ethernet0/1
ip address 20.0.0.1 255.0.0.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
ip address 30.0.0.1 255.0.0.0
!
interface Ethernet1/1
ip address 40.0.0.1 255.0.0.0
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
!
end



!
! Last configuration change at 15:07:25 IST Tue Oct 6 2015
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
clock timezone IST 5 30
!
!
!
!
!
!
!
!
!




!
!
!
no ip domain lookup


ip cef
no ipv6 cef
!
!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 10.0.0.1 255.255.255.0
!
interface Ethernet0/1
ip address 20.0.0.1 255.255.255.0
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
ip address 30.0.0.1 255.255.255.0
!
interface Ethernet1/1
ip address 40.0.0.1 255.255.255.0
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
ip forward-protocol nd
!
!
no ip http server
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
!
end

I am trying to configure the defualt routes on the client but is saying that gateway of the last resort is not set.

2

first of all it seams to be IOU lap enter image description here here you fail in many of the problems
1- you configured DHCP pool contain same range in router 450 and router 250 (10.0.0.0/24 and 10.0.0.0/8) which will result in iP conflict
2- essentially why you need to configure this DHCP server ?? , the networks which you configured as a DHCP pools already used as inter connect between routers , DHCP regularly used for a client or hosts behind the router (which will be sure in networks other than the networks used in conecting routers to each other)
3- just for the information if you aim to use router 450 as a DHCP server for clients behind other routers just use the IP helper command under the interface used as a GW for your client network

| improve this answer | |
  • The Dhcp pool in the router 250 was part of the older config. I removed that pool but seems it I posted the older config, my bad. I need a DHCP server to be outside the network as per the design of the network which my Boss has handed over to me. Thanks for pointing out that I need to configure the router 450 as the relay agent. – Rohit Saluja Oct 7 '15 at 6:12
1

I guess first I should provide the default routes on the client so that they know how to reach the DHCP server but even if i am trying to configure the ip routes on the client

Nope, clients discover DHCP server/s by sending a broadcast packet (DHCPDISCOVER, UDP packet from port 68 - bootpc - to 67 - bootps), consequently your DHCP server must be in the same broadcast domain of the clients to serve. As an kind of exception, a DHCP Relay Agent placed on the broadcast domain may be enough; basically, it forwards the DHCP messages from the clients in the network it connects to a remote DHCP server (command "ip helper x.x.x.x").

So, for instance, if interface Ethernet1/0 of Router 250 owns 30.0.0.1/8 (broadcast domain), either the config "ip dhcp pool DHCP350" on router 450 should be moved to the 250, or the 250 should be configured as DHCP Relay Agent towards the 450.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.