1

The logs from CISCO ASA fierwall is currently in the following format.

%ASA-message_class-severity-messageID

e.g.

   "%ASA-session-6-....."

I want to remove messsage class from logs

%ASA-severity-messageID

e.g.

   "%ASA-6-....."

I checked in internet and cicso configue help guide, then tried the commands

   no logging class session

But still coming the logs with message class. Please help me

   no logging emblem

Is this work?

Which is the actual command for that?

Thanks in advance.

4
  • Did you clear the log after applying that command?
    – Ron Maupin
    Oct 7 '15 at 13:44
  • No Ron. Thanks for ur reply. Could you tell me that these steps are correct or not?
    – apm
    Oct 7 '15 at 14:11
  • You appear to want to quit logging class 6 messages. cisco.com/c/en/us/td/docs/security/asa/asa82/command/reference/…
    – Ron Maupin
    Oct 7 '15 at 14:27
  • Not really. I want to remove the field "message_class" from the logs. I tried the command "no logging class session"
    – apm
    Oct 8 '15 at 5:38
1

Thanks for the comments and answers. I got the correct answer today. the first message is of emblem format and second one is default format.

We can go back to default format by using the following command

no logging emblem 

For more details look here

1
  • Accept your answer so that it doesn't keep popping up, looking for an answer, forever.
    – Ron Maupin
    Oct 8 '15 at 16:36
0

You can enable or disable classes or specific messages, but you can't change the message format. You will have to do that with an external program.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.