1

I have a generic ADSL router that supports dual bridge and pppoe mode. I have an ADSL account configured on the ADSL router, and have the same ADSL account configured as a pppoe connection on a cisco via 1 of the ethernet ports - so I can change the default route of hosts on the network to compare connections.

When using the connection via the generic router, I have stable transfers. However, internet usage on the Cisco is inconsistent and jitterish. For example, if I try upload a 2mb file via HTTP to a service (e.g. AWS S3), it seems to upload in bursts, and will sometimes fail. Is there anything obvious in my config below that may be slowing down the connection?

ip dhcp database nvram:dhcp.txt
ip dhcp pool localPool
  ! dhcp pool specifics configured.
ip inspect name FWOUT tcp
ip inspect name FWOUT udp
ip inspect name FWOUT https
ip inspect name FWOUT time
ip inspect name FWOUT ntp
ip inspect name FWOUT dns
ip inspect name FWOUT icmp
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
interface FastEthernet0/0
 description ETH-WAN and phys pppoe interface
 ip address 10.0.0.10 255.255.255.0
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 10
!
interface FastEthernet0/1
 description ETH-LAN
 ip address 192.168.1.1 255.255.255.0
 ip flow ingress
 ip flow egress
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip inspect FWOUT out
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 10
 ppp authentication pap callin
 ppp pap sent-username myaccount@myisp password 0 mypass
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip nat inside source list NAT_RULES interface Dialer1 overload

ip access-list extended NAT_RULES
 permit ip 192.168.1.0 0.0.0.255 any
ip access-list logging interval 100

This is not my full config - I have tunnel interfaces with crypto configs, lots more routes and a handful more access lists, but just wondering if there's anything in that config that might be causing the inconsistency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.