0

I'm trying to configure an ASA 5506 to allow ICMP and RDP through on GbE 1/3 and 1/4. These interfaces are internal only, as their own networks (20.10.10.0/24 and 30.10.10.0/24 -- non-internet destined or originating traffic).

I'm having trouble getting any machine on either network to ping each other, or pass RDP (20.10.10.5 -> 30.10.10.5 doesn't work, for example). I think I have messed something silly up, and am hoping someone could point me in the right direction.

Most of the configuration:

ASA Version 9.5(1) 
!
interface GigabitEthernet1/1
 nameif outside
 security-level 0
 ip address dhcp setroute 
!
interface GigabitEthernet1/2
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface GigabitEthernet1/3
 nameif L2
 security-level 0
 ip address 20.10.10.1 255.255.255.0 
!
interface GigabitEthernet1/4
 nameif L3
 security-level 0
 ip address 30.10.10.1 255.255.255.0 
!
interface GigabitEthernet1/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/6
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/7
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/8
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management1/1
 management-only
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object service RDP
 service tcp destination eq 3389 
access-list global_access extended permit object RDP any any 
access-list global_access extended permit icmp any any 
access-list global_access extended permit ip any any 
access-list L2_access_in extended permit ip 20.10.10.0 255.255.255.0 30.10.10.0 255.255.255.0 
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu L3 1500
mtu L2 1500
no failover
no monitor-interface service-module 
icmp unreachable rate-limit 1 burst-size 1
icmp permit any L3
icmp permit any L2
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network obj_any
 nat (any,outside) dynamic interface
access-group L2_access_in in interface L2
access-group global_access global
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside
!
dhcpd address 30.10.10.5-30.10.10.254 L3
dhcpd enable L3
!
dhcpd address 20.10.10.5-20.10.10.254 L2
dhcpd enable L2
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
dynamic-access-policy-record DfltAccessPolicy
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect ip-options 
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
: end
2

By default, a Cisco ASA does not permit traffic between two interfaces of the same security-level (L2 is 0 and L3 is 0). To enable traffic between the same security-levels, (SEE WARNING BELOW FIRST) use the "same-security-traffic permit inter-interface" command.

WARNING: With your current config, traffic from the outside interface will now be allowed into the L2 and L3 interfaces after running the command above because the Outside, L2 and L3 interfaces are at security-level 0. First, change the L2 and L3 interfaces to a higher security level so that traffic from the outside interface cannot get to L2 and L3 unless an Access-List permits it - especially since you've stated there are no destinations on L2 and L3 for the outside world.

Think of the security level as a hill where 0 is the bottom of the hill and 100 is the top of the hill. Now if you were a stream of water, you could not flow up the hill, but you could flow down it. Security levels act this way so that the ASA automatically prevents the traffic from the outside interface (security level 0) from getting to your inside interface (security level 100) unless allowed explicitly by an access-list. However, traffic can automatically flow down the hill. In other words traffic from security level 100 to security level 0 is automatically permitted unless otherwise stated in an access-list. So an interface with a security level of 50 could not automatically send traffic to an interface with a security level of 100 but could to an interface with a security-level of 0.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.