3

I was going through a Networking course online and they instructed me to try ping and traceroute commands on Linux for network checking.

I have Fedora OS v22 and am using WLAN Dlink Router for Internet connection. My private IP address is 192.168.0.103 and that of my router is 192.168.0.1. If I ping any website (e.g. google.com, stackoverflow.com, etc.), I am getting 100% packet loss. I asked a friend to share his public IP address, and, when I ping that IP, I still get 100% packet loss.

Neither is traceroute working. There is only 1 hop showing, which is that of my gateway 192.168.0.1 and the rest * * *.

What is the problem here? Have all the servers disabled their ICMP echo request? Are there some sites on which ping still works?

closed as off-topic by Ron Maupin Feb 26 at 23:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "NE is a site for to ask and provide answers about professionally managed networks in a business environment. Your question falls outside the areas our community decided are on topic. Please visit the help center for more details. If you disagree with this closure, please ask on Network Engineering Meta." – Ron Maupin
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it. – Ron Maupin Aug 6 '17 at 23:46
1

Many sites, including your friend's router, drop ICMP as a security feature. Pinging an entire domain such as google.com won't work unless there is a host responding on behalf of the domain. You can try to ping one of Google's DNS servers (e.g. 8.8.8.8). If that doesn't work, it may be that your router is blocking ICMP echo replies.

Traceroute can be a very different story. Some versions of traceroute use ICMP, but, originally, it was thought that a host should not respond to ICMP messages with an ICMP error message. The result is that many vendors implemented traceroute using UDP instead of ICMP. This can cause sites which block unsolicited UDP traffic to not respond to any version of traceroute using UDP.

There can be other problems, too. Any of the devices (routers, firewall, etc.) in the path from the source to the target may block your attempts. Some ISPs are implementing Carrier-Grade NAT (due to the IPv4 shortage), and the way some of them implement it seems to interfere with these tools.

  • I am using DLink 605 Router so I tried activating the WLAN Ping option to activate the ICMP echo request, but still I am getting Timeout on even 8.8.8.8 DNS Google Server. Any Advice? – Mohit Oct 22 '15 at 14:43
  • No. Questions about configuring consumer-grade equipment and home networking are both specifically off-topic. The place for those is on Super User. I tried to give you the background and most common reason for this, but you will have to ask elsewhere for the specifics of your situation. – Ron Maupin Oct 22 '15 at 14:51
1

Most likely your router or isp is blocking them. Your device may not block icmp outgoing but if it blocks incoming it can stop your ping.

Not the answer you're looking for? Browse other questions tagged or ask your own question.