1

This is an EIGRP Topology with frame relay. I'm not able to figure out why R1's topology table doesn't show feasible successor for 192.168.2.0/24?

P 192.168.1.0/24, 1 successors, FD is 2730496
        via 172.16.124.2 (2730496/2218496), Serial3/0
        via 172.16.124.3 (3193856/2681856), Serial3/0
P 192.168.2.0/24, 1 successors, FD is 2681856
        via 172.16.124.3 (2681856/2169856), Serial3/0
P 192.168.3.0/24, 1 successors, FD is 3193856
        via 172.16.124.3 (3193856/2681856), Serial3/0
        via 172.16.124.2 (3242496/2730496), Serial3/0

Topology looks like this: enter image description here

And why I'm receiving these messages on R5?

*Oct 24 05:28:10.455: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is up: new adjacency
R5(config-if)#
*Oct 24 05:28:23.559: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is down: Interface G                                                          oodbye received
R5(config-if)#
*Oct 24 05:29:05.299: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is up: new adjacency
R5(config-if)#
*Oct 24 05:32:09.819: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is down: retry limit                                                           exceeded
*Oct 24 05:32:10.107: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is down: Peer goodby                                                          e received
R5(config-if)#
*Oct 24 05:33:03.867: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is up: new adjacency
R5(config-if)#
*Oct 24 05:33:55.747: %SYS-5-CONFIG_I: Configured from console by console
R5#
*Oct 24 05:36:08.363: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is down: Peer goodbye received
R5#
*Oct 24 05:36:47.611: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is up: new adjacency
R5#
*Oct 24 05:39:52.047: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is down: Peer goodbye received
R5#
*Oct 24 05:40:30.191: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 172.16.124.1 (Serial3/3) is up: new adjacency

For information:

1) R1's neighbor table:

    R1#show ip eigrp neighbors
    IP-EIGRP neighbors for process 1
    H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                                (sec)         (ms)       Cnt Num
    1   172.16.124.4            Se3/0            178 00:00:10    1  5000  1  74
    2   172.16.124.2            Se3/0            120 00:15:34  987  5000  0  72
    0   172.16.124.3            Se3/0            147 00:15:34  138   828  0  77

2) R1's topology Table:



    R1#show ip eigrp topology
        IP-EIGRP Topology Table for AS(1)/ID(10.1.3.1)

        Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
               r - reply Status, s - sia Status

        P 10.2.0.0/22, 1 successors, FD is 2297856
                via 172.16.124.2 (2297856/128256), Serial3/0
        P 10.3.1.0/24, 1 successors, FD is 3370496
                via 172.16.124.2 (3370496/2858496), Serial3/0
        P 10.1.3.0/24, 1 successors, FD is 128256
                via Connected, Loopback3
        P 10.3.0.0/22, 1 successors, FD is 2297856
                via 172.16.124.3 (2297856/128256), Serial3/0
        P 10.2.1.0/24, 1 successors, FD is 3321856
                via 172.16.124.3 (3321856/2809856), Serial3/0
        P 10.1.2.0/24, 1 successors, FD is 128256
                via Connected, Loopback2
        P 10.3.3.0/24, 1 successors, FD is 3370496
                via 172.16.124.2 (3370496/2858496), Serial3/0
        P 10.2.2.0/24, 1 successors, FD is 3321856
                via 172.16.124.3 (3321856/2809856), Serial3/0
        P 10.1.1.0/24, 1 successors, FD is 128256
                via Connected, Loopback1
        P 10.3.2.0/24, 1 successors, FD is 3370496
                via 172.16.124.2 (3370496/2858496), Serial3/0
        P 10.2.3.0/24, 1 successors, FD is 3321856
                via 172.16.124.3 (3321856/2809856), Serial3/0
        P 192.168.1.0/24, 1 successors, FD is 2730496
                via 172.16.124.2 (2730496/2218496), Serial3/0
                via 172.16.124.3 (3193856/2681856), Serial3/0
        P 192.168.2.0/24, 1 successors, FD is 2681856
                via 172.16.124.3 (2681856/2169856), Serial3/0
        P 192.168.3.0/24, 1 successors, FD is 3193856
                via 172.16.124.3 (3193856/2681856), Serial3/0
                via 172.16.124.2 (3242496/2730496), Serial3/0
        P 172.16.124.0/29, 1 successors, FD is 2169856
                via Connected, Serial3/0
        P 172.16.120.0/21, 1 successors, FD is 3705856
                via 172.16.124.3 (3705856/3193856), Serial3/0
                via 172.16.124.2 (3754496/3242496), Serial3/0

        3) R1's routing table:

        R1#show ip route
        Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
               D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
               N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
               E1 - OSPF external type 1, E2 - OSPF external type 2
               i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
               ia - IS-IS inter area, * - candidate default, U - per-user static route
               o - ODR, P - periodic downloaded static route

        Gateway of last resort is not set

             172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
        C       172.16.124.0/29 is directly connected, Serial3/0
        D       172.16.120.0/21 [90/3705856] via 172.16.124.3, 00:09:57, Serial3/0
             10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
        D       10.3.1.0/24 [90/3370496] via 172.16.124.2, 00:09:57, Serial3/0
        D       10.2.0.0/22 [90/2297856] via 172.16.124.2, 00:09:57, Serial3/0
        C       10.1.3.0/24 is directly connected, Loopback3
        D       10.3.0.0/22 [90/2297856] via 172.16.124.3, 00:09:58, Serial3/0
        D       10.2.1.0/24 [90/3321856] via 172.16.124.3, 00:09:58, Serial3/0
        C       10.1.2.0/24 is directly connected, Loopback2
        D       10.3.3.0/24 [90/3370496] via 172.16.124.2, 00:09:57, Serial3/0
        D       10.2.2.0/24 [90/3321856] via 172.16.124.3, 00:09:58, Serial3/0
        C       10.1.1.0/24 is directly connected, Loopback1
        D       10.3.2.0/24 [90/3370496] via 172.16.124.2, 00:09:59, Serial3/0
        D       10.2.3.0/24 [90/3321856] via 172.16.124.3, 00:09:59, Serial3/0
        D    192.168.1.0/24 [90/2730496] via 172.16.124.2, 00:09:59, Serial3/0
        D    192.168.2.0/24 [90/2681856] via 172.16.124.3, 00:09:59, Serial3/0
        D    192.168.3.0/24 [90/3193856] via 172.16.124.3, 00:09:59, Serial3/0

Router's Running configs:

1) R1's running configs:

R1#show running-config
Building configuration...

Current configuration : 2166 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tImO$nXOKvyq7gRSwqCiLPJQJO.
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain EIGRP_KEYS
 key 1
   key-string cisco1
   accept-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
   send-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
 key 2
   key-string cisco2
   accept-lifetime 00:00:00 Jan 28 2015 infinite
   send-lifetime 00:00:00 Jan 28 2015 infinite
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.30.8.1 255.255.255.0
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial3/0
 ip address 172.16.124.1 255.255.255.248
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 network 172.30.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^C
*****************************
This is a CISCO ROUTER
*****************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end

1) R2's running configs & routing table:

R2#show running-config
Building configuration...

Current configuration : 2121 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$UbxQ$Vsto.IK7WKlg8MkuYywEs1
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain EIGRP_KEYS
 key 1
   key-string cisco1
   accept-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
   send-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface Loopback1
 ip address 10.2.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.2.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.2.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial3/0
 ip address 172.16.124.2 255.255.255.248
 encapsulation frame-relay
 ip summary-address eigrp 1 10.2.0.0 255.255.252.0 5
 serial restart-delay 0
 frame-relay map ip 172.16.124.3 201
!
interface Serial3/1
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^C
*****************************
This is a CISCO ROUTER
*****************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end

- R2's routing table;

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.124.0/29 is directly connected, Serial3/0
D       172.16.120.0/21 [90/3242496] via 192.168.1.2, 00:10:48, Serial3/1
     10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
D       10.3.1.0/24 [90/2858496] via 192.168.1.2, 00:10:46, Serial3/1
D       10.2.0.0/22 is a summary, 00:10:45, Null0
D       10.1.3.0/24 [90/2297856] via 172.16.124.1, 00:10:45, Serial3/0
D       10.3.0.0/22 [90/2809856] via 172.16.124.1, 00:10:48, Serial3/0
C       10.2.1.0/24 is directly connected, Loopback1
D       10.1.2.0/24 [90/2297856] via 172.16.124.1, 00:10:45, Serial3/0
D       10.3.3.0/24 [90/2858496] via 192.168.1.2, 00:10:46, Serial3/1
C       10.2.2.0/24 is directly connected, Loopback2
D       10.1.1.0/24 [90/2297856] via 172.16.124.1, 00:10:45, Serial3/0
D       10.3.2.0/24 [90/2858496] via 192.168.1.2, 00:10:46, Serial3/1
C       10.2.3.0/24 is directly connected, Loopback3
C    192.168.1.0/24 is directly connected, Serial3/1
D    192.168.2.0/24 [90/2730496] via 192.168.1.2, 00:10:49, Serial3/1
D    192.168.3.0/24 [90/2730496] via 192.168.1.2, 00:10:49, Serial3/1

3) R3's Running configs and routing table:

R3#show run
R3#show running-config
Building configuration...

Current configuration : 2273 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$fhTy$oS62/3CBdLhdKH89ogXQE0
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
key chain EIGRP_KEYS
 key 1
   key-string cisco1
   accept-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
   send-lifetime 00:00:00 Jan 1 2015 00:00:00 Feb 1 2015
 key 2
   key-string cisco2
   accept-lifetime 00:00:00 Jan 28 2015 infinite
   send-lifetime 00:00:00 Jan 28 2015 infinite
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface Loopback1
 ip address 10.3.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.3.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.3.3.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial3/0
 ip address 172.16.124.3 255.255.255.248
 encapsulation frame-relay
 ip summary-address eigrp 1 10.3.0.0 255.255.252.0 5
 serial restart-delay 0
 frame-relay map ip 172.16.124.2 301 broadcast
!
interface Serial3/1
 ip address 192.168.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial3/2
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^C
*****************************
This is a CISCO ROUTER
*****************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end

- R3's routing table:

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.124.0/29 is directly connected, Serial3/0
D       172.16.120.0/21 [90/3193856] via 192.168.2.1, 00:11:18, Serial3/2
     10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
C       10.3.1.0/24 is directly connected, Loopback1
D       10.2.0.0/22 [90/2809856] via 172.16.124.1, 00:11:16, Serial3/0
D       10.1.3.0/24 [90/2297856] via 172.16.124.1, 00:11:19, Serial3/0
D       10.3.0.0/22 is a summary, 00:11:18, Null0
D       10.2.1.0/24 [90/2809856] via 192.168.2.1, 00:11:18, Serial3/2
D       10.1.2.0/24 [90/2297856] via 172.16.124.1, 00:11:19, Serial3/0
C       10.3.3.0/24 is directly connected, Loopback3
D       10.2.2.0/24 [90/2809856] via 192.168.2.1, 00:11:18, Serial3/2
D       10.1.1.0/24 [90/2297856] via 172.16.124.1, 00:11:19, Serial3/0
C       10.3.2.0/24 is directly connected, Loopback2
D       10.2.3.0/24 [90/2809856] via 192.168.2.1, 00:11:19, Serial3/2
D    192.168.1.0/24 [90/2681856] via 192.168.2.1, 00:11:17, Serial3/2
C    192.168.2.0/24 is directly connected, Serial3/2
D    192.168.3.0/24 [90/2681856] via 192.168.2.1, 00:11:19, Serial3/2

4) R4's running configs and routing table:

R4#show running-config
Building configuration...

Current configuration : 1443 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial3/0
 ip address 192.168.3.2 255.255.255.0
 serial restart-delay 0
!
interface Serial3/1
 ip address 192.168.1.2 255.255.255.0
 serial restart-delay 0
!
interface Serial3/2
 ip address 192.168.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial3/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

- R4's routing table:

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.124.0/29 [90/2681856] via 192.168.2.2, 00:12:30, Serial3/2
                        [90/2681856] via 192.168.1.1, 00:12:30, Serial3/1
D       172.16.120.0/21 [90/2681856] via 192.168.3.1, 00:12:28, Serial3/0
     10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
D       10.3.1.0/24 [90/2297856] via 192.168.2.2, 00:13:27, Serial3/2
D       10.2.0.0/22 [90/3321856] via 192.168.2.2, 00:11:34, Serial3/2
D       10.1.3.0/24 [90/2809856] via 192.168.2.2, 00:11:34, Serial3/2
                    [90/2809856] via 192.168.1.1, 00:11:34, Serial3/1
D       10.3.0.0/22 [90/3321856] via 192.168.1.1, 00:11:36, Serial3/1
D       10.2.1.0/24 [90/2297856] via 192.168.1.1, 00:13:29, Serial3/1
D       10.1.2.0/24 [90/2809856] via 192.168.2.2, 00:11:34, Serial3/2
                    [90/2809856] via 192.168.1.1, 00:11:34, Serial3/1
D       10.3.3.0/24 [90/2297856] via 192.168.2.2, 00:13:28, Serial3/2
D       10.2.2.0/24 [90/2297856] via 192.168.1.1, 00:13:29, Serial3/1
D       10.1.1.0/24 [90/2809856] via 192.168.2.2, 00:11:34, Serial3/2
                    [90/2809856] via 192.168.1.1, 00:11:34, Serial3/1
D       10.3.2.0/24 [90/2297856] via 192.168.2.2, 00:13:28, Serial3/2
D       10.2.3.0/24 [90/2297856] via 192.168.1.1, 00:13:29, Serial3/1
C    192.168.1.0/24 is directly connected, Serial3/1
C    192.168.2.0/24 is directly connected, Serial3/2
C    192.168.3.0/24 is directly connected, Serial3/0

5) R5's running configs and routing table:

    R5#show running-config
Building configuration...

Current configuration : 1675 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$bO2q$Yzyc3mFfHaiVGiOOlz27l0
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 no ip address
 shutdown
 negotiation auto
!
interface Serial3/0
 bandwidth 1500
 ip address 192.168.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/3
 ip address 172.16.124.4 255.255.255.248
 encapsulation frame-relay
 serial restart-delay 0
!
router eigrp 1
 network 172.16.0.0
 network 192.168.3.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^C
*****************************
This is a CISCO ROUTER
*****************************^C
!
line con 0
 exec-timeout 0 0
 privilege level 15
 password cisco
 logging synchronous
 login
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end

R1's topology table still doesn't show feasible successor for 192.168.2.0/24

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.3.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.2.0.0/22, 1 successors, FD is 2297856
        via 172.16.124.2 (2297856/128256), Serial3/0
P 10.3.1.0/24, 2 successors, FD is 3370496
        via 172.16.124.2 (3370496/2858496), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 10.1.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 10.3.0.0/22, 1 successors, FD is 2297856
        via 172.16.124.3 (2297856/128256), Serial3/0
P 10.2.1.0/24, 1 successors, FD is 3321856
        via 172.16.124.3 (3321856/2809856), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 10.1.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
P 10.2.2.0/24, 1 successors, FD is 3321856
        via 172.16.124.3 (3321856/2809856), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 10.3.3.0/24, 2 successors, FD is 3370496
        via 172.16.124.2 (3370496/2858496), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 10.1.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.2.3.0/24, 1 successors, FD is 3321856
        via 172.16.124.3 (3321856/2809856), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 10.3.2.0/24, 2 successors, FD is 3370496
        via 172.16.124.2 (3370496/2858496), Serial3/0
        via 172.16.124.4 (3370496/2858496), Serial3/0
P 192.168.1.0/24, 1 successors, FD is 2730496
        via 172.16.124.2 (2730496/2218496), Serial3/0
        via 172.16.124.3 (3193856/2681856), Serial3/0
P 192.168.2.0/24, 1 successors, FD is 2681856
        via 172.16.124.3 (2681856/2169856), Serial3/0
P 192.168.3.0/24, 1 successors, FD is 2730496
        via 172.16.124.4 (2730496/2218496), Serial3/0
        via 172.16.124.3 (3193856/2681856), Serial3/0
P 172.16.124.0/29, 1 successors, FD is 2169856
        via Connected, Serial3/0
  • You don't provide any configuration details to help with the bouncing neighbor. It is likely that R5 has configuration error(s), but the problem may be with R1. You should provide as much detail as possible, and I don't mean just the EIGRP configurations, but the serial port configurations, too. – Ron Maupin Oct 24 '15 at 0:33
  • In R1's topology table, you only have one route to 192.168.2.0/24. You seem to have multiple configuration errors on multiple routers. You have not shared any router configurations, so how do you propose we troubleshoot this? – Ron Maupin Oct 24 '15 at 0:49
  • @RonMaupin I've updated the question with all configurations. Please have a check. – Heisenberg Oct 24 '15 at 1:17
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 17:51
2

On R5, Ser 3/3 has an incorrect mask. You have 255.255.248.0. It should be 255.255.255.248.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.