3

I have a SOHO environment for which I'm using Cisco 891-K9 as the ISP GW. But the nature of Cisco 891 is that it's both a router and a switch with 10 ports.

Will switch ports (both access and trunk ports) be properly forwarding broadcast packets/DHCP requests for VLAN or VLANs or would only trunk ports propagate? Is is the case for 891 where, broadcast packets do not flood within one device?

1st option I have is router on stick:

!
interface FastEthernet8
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet8.2
 encapsulation dot1Q 10
 ip address 10.2.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 no cdp enable
!
interface FastEthernet8.70
 encapsulation dot1Q 70
 ip address 10.70.0.1 255.255.252.0
 ip nat inside
 ip virtual-reassembly in
 no cdp enable
!
!
ip dhcp pool VLAN70
 network 10.70.0.0 255.255.252.0
 dns-server 8.8.8.8 8.8.4.4 
 default-router 10.70.0.1 
!
ip dhcp pool VLAN2
 network 10.2.10.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4 
 default-router 10.2.10.1
!

2nd option via SVI:

!
interface FastEthernet0
 switchport mode trunk
 no ip address
!
interface Vlan2
 ip address 10.2.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan70
 ip address 10.70.0.1 255.255.252.0
 ip nat inside
 ip virtual-reassembly in
!

!
ip dhcp pool VLAN70
 network 10.70.0.0 255.255.252.0
 dns-server 8.8.8.8 8.8.4.4 
 default-router 10.70.0.1 
!
ip dhcp pool VLAN2
 network 10.2.10.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4 
 default-router 10.2.10.1
!

Most routers, as far as I've encountered, can only do sub-interface, but seems 891 is a unique case.

0

You have a traditional 2-port router trunking to an 8-port switch. The 891 has two router ports which can be used like traditional router ports. These two ports are usually used for WAN connections, but one or both can be set up with subinterfaces, etc. as traditional router ports.

The other eight ports are switch ports and act like a switch, and cannot be used as router ports. Many of the ISR routers can use a switch module; this router just has it built in. To use the switch ports, you can use SVIs and assign VLANs to the switch ports. You can even set them up as trunk ports, but you can't use them as router ports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.