1

I am noticing that our Dell N4000 series switch connected to a stack of Cisco devices is constantly attempting to change spanning tree topology. The Cisco switch is our Internet connection and a fiber loop that connects to our other offices.

My logs are:
<189> Nov 6 09:34:36 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7355 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 09:34:35 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7354 %% Spanning Tree Topology Change: 0, Unit: 1 <189> Nov 6 09:34:35 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7353 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 09:28:26 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7352 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 09:28:25 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7351 %% Spanning Tree Topology Change: 0, Unit: 1 <189> Nov 6 09:28:25 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7350 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 08:38:20 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7347 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 08:38:19 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7346 %% Spanning Tree Topology Change: 0, Unit: 1 <189> Nov 6 08:38:19 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7345 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1 <189> Nov 6 08:29:16 SW105-1 TRAPMGR[dot1s_task]: traputil.c(777) 7344 %% Spanning Tree Topology Change Received: MSTID: 0 Te1/0/1

The only config on the port is:
switchport mode general switchport general pvid 10 switchport general allowed vlan add 10

Would it be best to enable tcn guard and bpdu filter on this port?

3
  • Do you want to disable STP on this ports or do you want to make STP work properly? In my experience, I never implement STP between core switches and ISP routers.
    – KorXo
    Nov 6 '15 at 16:49
  • You may want to look at this question: networkengineering.stackexchange.com/questions/23679/…
    – Ron Maupin
    Nov 6 '15 at 17:48
  • Thanks. So it looks like my best option is to turn off STP for this port.
    – DanielJay
    Nov 9 '15 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.