3

I'm using an EdgeMAX router. From the GUI, I'm trying to forward the WAN (eth1) port 22 to the LAN (eth2) port 22 to a local IP address (172.16.12.3) to allow SSH from outside my network. When I tried to SSH I get a time out error. I tried to troubleshoot in all imaginable ways:

  1. I've checked my firewall for rules that might drop that connection attempt.
  2. I tried to port forward to two others local IP addresses successfully from WAN 2222 to LAN 22, and I managed to connect through SSH on those two machines.
  3. I've tried to change the SSH port on the target machine (172.16.12.3).
  4. I've disabled the firewall on the local target machine (172.16.12.3).
  5. Since the 2222 port worked for the two other machines (item 2), I also tried to port forward from that port to a different port (22,2222) on the target machine (172.16.12.3)

Of course the target machine is reachable from inside the LAN. I don't have any more ideas about what could be wrong! any suggestions?

8
  • if the target a linux or unix machine you should look into enabling ssh on it by running the cmds. Also when you say you can reach it locally, can you telnet to it using port 22?
    – allwynmasc
    Nov 12 '15 at 15:29
  • 2
    Is the default gateway correct on the target machine? Can it reach the Internet?
    – Ron Trunk
    Nov 12 '15 at 15:29
  • What device are you attempting to SSH to? That would be my first question. Have you checked the SSH configuration on that device? Nov 12 '15 at 16:03
  • i'm trying to SSH a linux server, i've check it's ssh config and i can SSH that device from a LAN machine. Nov 13 '15 at 7:01
  • Ron Truk, i've thought of many issues that i've forgotten the basis : i didn't think to check the internet connection from the target machine (what an idiot i've been!). Indeed the target machine could't reach the Internet. So the question is becoming "Why can it reach the internet while its network configuration is right?" i've checked the gateway, the net mask, the DNS,... but everything seem right. Nov 13 '15 at 11:01
1

Finally solved! i don't know why but an other interface was set in DHCP mode (not allowed in here, only static addresses can go to the WAN), i disabled this interface and things got back to normal. Thank you everyone for your answers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.