3

I have two network segments connected to a single Cisco router by Cisco switches. I've enabled multicast routing on the router by running following commands:

  1. ip multicast-routing in configuration mode
  2. ip pim dense-mode on each interface

And set following route on the hosts for multicast traffic:

  1. route add -net 224.0.0.0 netmask 240.0.0.0 dev eth2

According to my searches the multicast traffic should cross the networks without setting route for their network (128.238.61.0 and 128.238.62.0 here), but is not the case. I tried following solutions, but neither worked:

  1. Using sparse-mode and dense-sparse-mode for interfaces
  2. Enabling and disabling Reverse path filtering from /proc/sys/net/ipv4/conf/[all,defalut,eth2]/rp_filter by writing 0 and 2 in it.

I use netspy to create multicast traffic and groups (224.111.111.111) and I've verified that the corresponding address is in the multicast groups of router interfaces. Also hosts inside a single network segment can see the multicast traffic properly. As I think the traffic should cross the networks without setting route, what misconfigurations may cause this problem. Thank you in advance.

There is one router with interface IPs: 128.238.61.1/24 and 128.238.62.1/24. To each port of the router a switch is connected. To each switch three hosts are connected. I connect to router by telnet and then type config term. Then I type ip multicast-routing. I go to interfaces with command int fa 0/0 (0/1) and type ip pim dense-mode. Then on the host with ip 128.238.61.109/24 I start netspy by typing netspyd 224.111.111.111 1500 6 (parameters are group ip, port and ttl). Now on all other hosts I type netspy 224.111.111.111 1500. Now if I telnet from one of the hosts on the same side as the netspyd to it (109) nothing happens. If I set on all hosts route route add -net 224.0.0.0 netmask 240.0.0.0 dev eth2 and then do the telnet hosts on the same side of as the netspyd server (network 61.0) get the message about the log on but others don't.

Best,

  • Do a show running-configuration and paste that in to your question. You don't need to configure PIM unless you are connecting this router to another router in order to route multicast to the other router. As I wrote a couple of times, PIM is a router-to-router protocol. You need to be concerned with IGMP, and I don't see where you are configuring that. – Ron Maupin Nov 15 '15 at 17:46
  • Thank you. To configure IGMP for router I searched right now and found this link conf igmp. Is it sufficient to give command ip igmp version value to router in order to config it? For hosts I found this which says to set route. Currently I can't send the output of that command, but I will add it. – Mahdi Dolati Nov 15 '15 at 18:04
  • I think you are misunderstanding how multicast works. The router will not forward the multicast traffic from one interface to the other unless a host in the receiving network has sent an IGMP join message to the router. The host will not do that unless it is running an application which joins the multicast group. You don't list the applications you are using for multicast. You have an application on one side which generates multicast traffic for a specific group. On the other side, you need a host with an application which joins that group. You don't seem to know how this really works. – Ron Maupin Nov 15 '15 at 18:11
  • You don't seem to have an application which joins the multicast group and sends IGMP to the router. The idea of multicast is that it is a selective broadcast; hosts ignore multicasts unless they have actually subscribed to the multicast group. You need a proper multicast source, and an application on the hosts to receive the multicasts. There are tools to do this if you search the Internet. – Ron Maupin Nov 15 '15 at 18:15
  • Isn't the netspy is that application? According to my experiments the multicast send and receive works with netspy within a single network and after setting the route for 224.111.111.111. – Mahdi Dolati Nov 15 '15 at 18:20
1

PIM is a router-to-router protocol. I think what you are missing is IGMP. The clients wanting to receive traffic from a multicast groups will use IGMP to inform the router that they wish to receive the traffic:

enter image description here

Based on your configuration commands, I assume you are using a Cisco router. Cisco has a document which describes all of this and how to configure multicast routing.

  • Thank you, I read the article, and yes I use Cisco. The route for 224.0.0.0 was placed on the hosts and they could send and receive IGMP messages (checked by wireshark) and when I run show ip igmp group on the interfaces of the router I can see multicast address (224.111.111.111) on both. Can't I say that IGMP is properly configured? – Mahdi Dolati Nov 13 '15 at 21:03
  • Why are you placing a route 224.0.0.0 on the hosts? Multicast doesn't route like that since the hosts are receiving multicast; even on a router you use mroute instead of route. You didn't show your configurations so that we can see where you may have gone wrong. You should also use a proper multicast address from the Administratively Scoped range (239.0.0.0/8) because randomly picking multicast addresses can cause problems. – Ron Maupin Nov 13 '15 at 21:18
  • As the network space of hosts differ from multicast space, If I don't add route how multicast packets are routed? I think all class D addresses ranging from 224.0.0.0 to 239.255.255.255 are for multicast, so used 224.0.0.0. And that's pretty much all of my configurations: multicast on router, pim on interfaces and route add -net 224.0.0.0 netmask 240.0.0.0 dev eth2 on hosts. Also my hosts are connected to router via switches, do I need to enable CGMP? – Mahdi Dolati Nov 13 '15 at 21:57
  • You don't put a multicast route on the hosts. Hosts receive multicasts for groups to which they subscribe. PIM isn't needed on the router unless you are routing multicasts to another router; PIM is a router-to-router protocol. CGMP isn't necessary for multicast to work, it allows a switch to disable multicasts on ports for which nothing has subscribed to a multicast group. You need to edit your question with the actual configurations so that we can see where you may have gone wrong. Telling us what you have configured, and what you actually configured, can be very different. – Ron Maupin Nov 13 '15 at 22:08
  • Dear Ron, I added more details about what I'm doing. Furthermore, today I checked that without setting route for 224.0.0.0 even the hosts on the same network cannot see the multicast traffic from the netspy server which sends multicast traffic. So I think the route is necessary. Thank you. – Mahdi Dolati Nov 15 '15 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.