1

I am trying to identify the size of memory available on the CISCO router. I do not have physical access to the router but I am able to login to the console and fire commands in privilege mode. I see that Flash and NVRAM memory sizes have been explicitly called out, but I don't see any information for RAM, and ROM.

Here are some snippets from the show version command,

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)


cisco 2811 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory
Processor board ID JAD05190MTZ (4292891495)
M860 processor: part number 0, mask 49
2 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
239K bytes of NVRAM.
62720K bytes of processor board System flash (Read/Write)

Also in the line - "cisco 2811 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory" how do I interpret "60416K/5120K"?

2

When you see a line like with 60416K/5120K bytes of memory in a router, this indicates the amount of DRAM and packet memory installed in the router. For many platforms, part of the DRAM is assigned to packet memory, so you take this in two ways:

  1. If the first number is a "normal" amount of RAM (binary or multiple of two), use only the first number. For examples from a 4500 switch, the following output would indicated 64M of RAM: 65536K/2072K bytes of memory
  2. Otherwise, you will need to add the two numbers. In the example you provided, you would add the two and also get 64M of RAM.

While there are many ROM only components in many Cisco devices, usually this is used as a misnomer for persistent storage on the device (i.e. where the bootable images, configuration, and other such files are stored), also often referred to as flash or NVRAM. After all, we don't really care how much ROM is installed as you can't use ROM memory.

The line 62720K bytes of processor board System flash (Read/Write) clearly indicates how much you have installed.

Now some routers and switches will allow you to use other sources of flash as well, such as compact flash. So this is another source of storage that may not be represented on a show version.

3

When you see 60416K/5120K in the show version command, it is telling you that you have 60416K of main memory and 5120K of shared memory.

The show memory command will show you about the memory, and it has a bunch of options:

Router1#show memory ?
  <0-4294967294>      Dump memory starting at <address>
  allocating-process  Show allocating process name
  console             Console memory
  dead                Memory owned by dead processes
  debug               Memory debugging commands
  failures            Memory failures
  fast                Fast memory stats
  fragment            Summary of memory fragment information
  free                Free memory stats
  io                  IO memory stats
  lite-chunks         Malloc lite info
  multibus            Multibus memory stats
  overflow            memory overflow corrections
  pci                 PCI memory stats
  processor           Processor memory stats
  statistics          Mempool Statistics
  summary             Summary of memory usage per alloc PC
  transient           Transient memory stats
  |                   Output modifiers
  <cr>

Router1#show memory statistics
                Head    Total(b)     Used(b)     Free(b)   Lowest(b)  Largest(b)
Processor    F96C068   289042648   117972352   171070296   137846436   149146964
      I/O   1DD13140    36622016    17281324    19340692    18933200    18360124

You're not really specific about what you are looking for. There are a lot of different show commands that can give you different statistics. It's not really like a Windows PC, if that is the sort of thing you are looking for.

Edit:

Router1#show processes memory
Processor Pool Total:  289042648 Used:  118031228 Free:  171011420
      I/O Pool Total:   36622016 Used:   17278752 Free:   19343264

 PID TTY  Allocated      Freed    Holding    Getbufs    Retbufs Process
   0   0  182017988   71112816  105430820       2426     311700 *Init*          
   0   0      13124     238360      13124          0          0 *Sched*         
   0   0   45943548   44545972    1372356          2          1 *Dead*          
   0   0          0          0     394968          0          0 *MallocLite*    
   1   0  114617512  110099076    4525732          0          0 Chunk Manager   
   2   0        240        240       4296          0          0 Load Meter      
   3   0     159196     152332      32076          0          0 Exec            
   4   0      65588          0      90884          0          0 EDDRI_MAIN      
   5   0          0          0       7296          0          0 RO Notify Timers
   6   0       3376        240      10432          0          0 Check heaps     
   7   0 1224604664 1227210180     218940         49          0 Pool Manager    
   8   0          0          0       7296          0          0 DiscardQ Backgro
   9   0        240        240       7296          0          0 Timers          
  10   0          0          0       4296          0          0 WATCH_AFS   

For File systems:

Router1#show file systems
File Systems:

       Size(b)       Free(b)      Type  Flags  Prefixes
             -             -    opaque     rw   archive:
             -             -    opaque     rw   system:
             -             -    opaque     rw   tmpsys:
             -             -    opaque     rw   null:
             -             -   network     rw   tftp:
*    256503808      78442496      disk     rw   flash:#
        262136        248681     nvram     rw   nvram:
             -             -    opaque     wo   syslog:
             -             -    opaque     rw   xmodem:
             -             -    opaque     rw   ymodem:
             -             -   network     rw   rcp:
             -             -   network     rw   http:
             -             -   network     rw   ftp:
             -             -   network     rw   scp:
             -             -    opaque     ro   tar:
             -             -   network     rw   https:
             -             -    opaque     ro   cns:
             -             -    opaque     rw   security:
  • Thanks for the response Ron, I tried to look for show memory command in the privilege mode and it's not available, ciscoasa#show memory ^ % Invalid input detected at '^' marker. – Yazad Nov 15 '15 at 15:20
  • I am voting you up anyways since your explanation of shared and main memory was helpful. If you can offer more inputs on the command to use instead of show memory, that would be very helpful. – Yazad Nov 15 '15 at 15:22
  • 1
    Is this a Cisco ASA, or is it a Cisco 2811 router? There is a difference. There is also the show processes command, and it has options, too. – Ron Maupin Nov 15 '15 at 15:25
  • Thanks Ron, the show version command indicates "Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)", does this help determining the router? I also tried "show processes memory" but that gave an error only "show processes" works, but that doesn't help with memory information I needed. – Yazad Nov 15 '15 at 15:35
  • What is it, specifically, that you need, and why? It's not like can are going to be running your own applications on a 2811 router. There are all kinds of show commands, but I'm not completely sure what you are after, or why you want it. There may be something that fits your needs but I don't understand what you are trying to do, so I can't narrow it down for you. – Ron Maupin Nov 15 '15 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.