2

We have ws-c3850-48t two switch in stack. and from Internet Provide ISP we have two fiber drops coming for redundancy. I want to configure HSRP for failover but i believe stack switch work like single virtual switch. so I am confused whether it is doable or not or if yes then how it will work?

    _________________
   [_______ISP_______]
     |             |
     |             | 
 10G |             | 10G  (links) 
   ___________________
  [__ 2x stack SW ____]

Question:

Q1. Does `HSRP` suggestible on stack switches?
Q2. Is there any alternation for gateway redundancy? 

Update: I am getting /30 IP pool for handoff and /23 IP pool for my server firm from my ISP.

So that way i have to configure IP address on my L3 switch port and configure HSRP right to failover right??

  • 1
    A stacked switch is effectively a single switch. If you've got two fibre links from the same ISP, have them set up BGP, It's trivial when both links are from the same ISP (I'd check to ensure that the links are going to two separate PoPs, or at least two different network segments in the same PoP) – stevieb Nov 24 '15 at 16:36
  • Yes that link coming from same ISP but its just physical fiber link.. it is just for standby, in case fiber cut for switch fail.. we have second link to run packets.... – Satish Nov 24 '15 at 17:53
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it. – Ron Maupin Aug 6 '17 at 23:03
2

HSRP would be configured on the ISP side, not your side.

The switch will look and be configured like a single switch.

You will use the no switchport command on the two interfaces to the ISP. Each interface would be configured as a router interface and each would have an IP address. It will look something like this:

interface GigabitEthernet1/0/0
 no switchport
 ip address 1.1.1.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
 no shutdown
!
interface GigabitEthernet2/0/0
 no switchport
 ip address 2.2.2.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
 no shutdown
!

Since you are now considering using a port channel:

interface GigabitEthernet1/0/0
 no switchport
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
 channel-group 1 mode on
 no shutdown
!
interface GigabitEthernet2/0/0
 no switchport
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
 channel-group 1 mode on
 no shutdown
!
interface PortChannel1
 no switchport
 ip address 1.1.1.2 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable
 no shutdown
!

Note:

You really should have a firewall between the ISP and your switch stack. Also, you can't use NAT on the switch, you would need a router for that.

  • Why not configure HSRP on my side? I am getting handoff IP and then server IP pool from ISP /23. its L3 switch so i have to configure IP address on sw port and terminate ISP link. so i can create subnet and and play with /23 subnet. – Satish Nov 24 '15 at 17:52
  • We are running iptables firewall on all hosts, so we don't have dedicated firewalls. – Satish Nov 24 '15 at 18:17
  • I would happy if you solve my existing problem.. i will deal with security later. Believe me whatever we are dealing right now it has zero security issue. I need things working. I just want to know how i can have redundancy with stack switch... – Satish Nov 24 '15 at 18:35
  • So you suggesting, terminate two fiber on stack switch and configure IP address on both fiber ports right? and then configure IP route to with 100 and 200 weight ?? am i right? what if one of my stack switch failed? – Satish Nov 24 '15 at 19:02
  • In even in that case i have to configure VLAN and assign IP address to switch port which is connected to ISP router right? – Satish Nov 24 '15 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.