3

I am trying to do this: Load Sharing When Dual-Homed to One ISP Through Multiple Local Routers. The only difference from the example is that the ISP is sending a full BGP table instead of the default gateway. I have a problem that R101 won't advertise external routes to R102, which causes problem when R102's upstream peer disconnects, and R102 loses all routes.

My configuration:

R101 running configuration:

router bgp 6001
 no synchronization
 bgp router-id 1.1.2.253
 bgp log-neighbor-changes
 network 1.1.1.0
 network 1.1.2.0
 neighbor 2.1.1.249 remote-as 6000
 neighbor 2.1.1.249 soft-reconfiguration inbound
 neighbor 2.1.1.249 prefix-list 3 in
 neighbor 2.1.1.249 route-map R1-DC-MAP out
 neighbor 1.1.2.254 remote-as 6001
 neighbor 1.1.2.254 next-hop-self
 neighbor 1.1.2.254 soft-reconfiguration inbound
 maximum-paths 2
 no auto-summary
!
ip prefix-list 1 seq 5 permit 1.1.1.0/24
ip prefix-list 2 seq 5 permit 1.1.2.0/24
ip prefix-list 3 seq 5 deny 1.1.1.0/23
ip prefix-list 3 seq 10 permit any
!
route-map R1-DC-MAP permit 10
 match ip address prefix-list 1
 set as-path prepend 6001 6001 6001
!
route-map R1-DC-MAP permit 20
 match ip address prefix-list 2
!
route-map R1-DC-MAP deny 200

R102 running configuration:

router bgp 6001
 no synchronization
 bgp router-id 1.1.2.254
 bgp log-neighbor-changes
 network 1.1.1.0
 network 1.1.2.0
 neighbor 3.1.1.25 remote-as 6000
 neighbor 3.1.1.25 soft-reconfiguration inbound
 neighbor 3.1.1.25 prefix-list 3 in
 neighbor 3.1.1.25 route-map R2-SIX-MAP out
 neighbor 1.1.2.253 remote-as 6001
 neighbor 1.1.2.253 next-hop-self
 neighbor 1.1.2.253 soft-reconfiguration inbound
 maximum-paths 2
 no auto-summary
!
ip prefix-list 1 seq 5 permit 1.1.2.0/24
ip prefix-list 2 seq 5 permit 1.1.1.0/24
ip prefix-list 3 seq 5 deny 1.1.1.0/23
ip prefix-list 3 seq 10 permit any
!
route-map R2-SIX-MAP permit 10
 match ip address prefix-list 1
 set as-path prepend 6001 6001 6001
!
route-map R2-SIX-MAP permit 20
 match ip address prefix-list 2
!
route-map R2-SIX-MAP deny 30
 match ip address 1.1.1.0/23
!
route-map R2-SIX-MAP deny 200
!
ip forwarding
!
line vty
!
end

R101 interface list:

Interface vlan3 is up, line protocol detection is disabled
  inet 1.1.1.253/30 broadcast 1.1.1.255

Interface vlan4 is up, line protocol detection is disabled
  inet 2.1.1.253/29 broadcast 2.1.1.255

Interface vlan101 is up, line protocol detection is disabled
  inet 1.1.1.61/26 broadcast 1.1.1.63
  inet 1.1.1.1/32 broadcast 1.1.1.1

Interface vlan106 is up, line protocol detection is disabled
  inet 1.1.1.125/27 broadcast 1.1.1.127
  inet 1.1.1.97/32 broadcast 1.1.1.97

Interface vlan107 is up, line protocol detection is disabled
  inet 1.1.1.141/28 broadcast 1.1.1.143
  inet 1.1.1.129/28 broadcast 1.1.1.143 secondary

Interface vlan109 is up, line protocol detection is disabled
  inet 1.1.1.93/27 broadcast 1.1.1.95
  inet 1.1.1.65/32 broadcast 1.1.1.65

R102 interface configuration:

Interface vlan3 is up, line protocol detection is disabled
  inet 1.1.2.254/30 broadcast 1.1.2.255

Interface vlan4 is up, line protocol detection is disabled
  inet 3.1.1.29/29 broadcast 3.1.1.31

Interface vlan101 is up, line protocol detection is disabled
  inet 1.1.2.62/26 broadcast 1.1.2.63
  inet 1.1.2.1/32 broadcast 1.1.2.1

Interface vlan106 is up, line protocol detection is disabled
  inet 1.1.2.126/27 broadcast 1.1.2.127
  inet 1.1.2.97/32 broadcast 1.1.2.97

Interface vlan107 is up, line protocol detection is disabled
  inet 1.1.2.142/28 broadcast 1.1.2.143
  inet 1.1.2.129/28 broadcast 1.1.2.143 secondary

Interface vlan109 is up, line protocol detection is disabled
  inet 1.1.2.94/27 broadcast 1.1.2.95
  inet 1.1.2.65/32 broadcast 1.1.2.65

Advertisements are not working at all on R101, but I can see advertisements coming from R102. Communication with the upstream ISP BGP peers works as expected, and I am obtaining full BGP from them.

R101 advertisements:

BGP table version is 0, local router ID is 1.1.2.253
Status codes: s suppressed, d damped, h history, * valid, > best, = multipath,
              i internal, r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

R101 received-routes:

BGP table version is 0, local router ID is 1.1.2.253
Status codes: s suppressed, d damped, h history, * valid, > best, = multipath,
              i internal, r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0     1.1.2.254           0    100      0 i
*> 1.1.2.0     1.1.2.254           0    100      0 i

Total number of prefixes 2

Does anyone have any ideas what may be wrong?

1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 12 '17 at 21:45
1

The network statements in your BGP router configuration:

network 1.1.1.0
network 1.1.2.0

do not match the actual network addresses, which range from /26 to /32. BGP will not advertise networks which do not exactly match what is in the routing table unless you you use the aggregate-address command. Network statements in BGP will not make up routes that don't already exist.

0

I guess that the problem is with your supporting routes for 1.1.1.0/24 and 1.1.2.0/24.

To announce a prefix, you need a supporting route in RIB. So, you should have 1.1.1.0/24 and 1.1.2.0/24 in RIB to be able to announce them.

I assume you can't change your SVI's IP addressing, thus maybe you can enter two /24 routes towards the south of your network, or to Null0. Then the BGP network command will take effect.

2
  • I added "ip route 1.1.1.0/24 null0" and "ip route 1.1.2.0/24" to both R101 and R102, but the behavior is the same. Nov 27 '15 at 0:15
  • Have you tried to clear ip bgp? Sep 22 '16 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.