0

Please help me I don't know what is wrong in my configuration. OSPF is not working.

enter image description here

ROUTER 1:

int g0/0
ip add 210.1.1.1 255.255.255.224
no shut

int s0/0/1
ip add 172.20.0.222 255.255.255.252
no shut

ROUTER 0:

int g0/0
ip add 172.20.0.129 255.255.255.224
no shut

int s0/0/1
ip add 172.20.0.221 255.255.255.252
no shut

int s0/0/0
ip add 172.20.0.218 255.255.255.252
no shut

router ospf 1
router-id 2.2.2.2

network 172.20.0.128 0.0.0.31 area 0
network 172.20.0.220 0.0.0.3 area 0
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide your own answer and accept it. – Ron Maupin Aug 7 '17 at 15:29
2

You don't have OSPF configured on both routers. The point of a routing protocol is to share routes with other routers. It does no good to run OSPF on only one router.

You need to configure OSPF on Router 1 like you did on Router 0. If you include all the routes connected to Router 1 in the OSPF configuration for Router 1, Router 0 should be able to see them, and Router 1 should be able to see the routes on Router 0.

| improve this answer | |
1

You need to configure Router1 like you did on Router0. Also you can capture packets (ie. Wireshark) to check OSPF hello packets, if routers are sending them then OSPF on that router should be up.

For example: (ROUTER 1)

interface g0/0
ip address 210.1.1.1 255.255.255.224
no shutdown

interface s0/0/1
ip address 172.20.0.222 255.255.255.252
no shutdown

router ospf 1
router-id 1.1.1.1

network 210.1.1.1 0.0.0.31 area 0
network 172.20.0.222 0.0.0.3 area 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.