1

Here is the Diagram. enter image description here

Ip address:

ISP:

[VIP]- 10.107.25.5
[R1] - 10.107.25.6
[R2] - 10.107.25.7

Me:

[VIP] - 10.107.25.10
[SW1] - 10.107.25.11
[SW2] - 10.107.25.12

Configuration on port:

SW1


    interface GigabitEthernet1/0/1
    description #Primary Link WTBB 1#
    no switchport
    ip address 10.107.25.11 255.255.255.248
    standby 30 ip 10.107.25.10
    standby 30 priority 110
    standby 30 preempt

SW2


    interface GigabitEthernet1/0/1
    description # Secondary Link WTBB 2#
    no switchport
    ip address 10.107.25.12 255.255.255.248
    standby 30 ip 10.107.25.10
    no standby 30 preempt

Notes: Interesting thing i can't ping from 10.107.25.11 to 10.107.25.12 I am not sure what is other side of ISP, As per document .11 should ping .12 so they can say hello to each other using L2 layer right?

This is what i did but i think its wrong way to configure HSRP

[SW1]

interface vlan3
ip address 10.107.25.11 255.255.255.248
standby 30 ip 10.107.25.10
standby 30 priority 110
standby 30 preempt 

interface GigabitEthernet1/0/1
switchport access allow vlan 3

[SW2]

interface vlan3
ip address 10.107.25.12 255.255.255.248
standby 30 ip 10.107.25.10
standby 30 priority 110
standby 30 preempt 

interface GigabitEthernet1/0/1
switchport access allow vlan 3

On Trunk interface i allowed Vlan3

Now i can ping from .11 to .12 ip address using vlan3 (L2) network. and HSRP is happy (active/standby).

But if i unplug cable on port G1/0/1 trying to mimic cable is cut and my VIP will failover. but problem is .11 and .12 is on vlan3 interface and they are UP no matter you cut the cable or not..

How do i solve this issue in above scenario?

4
  • What are the switch models, and how are they connected together?
    – Ron Maupin
    Dec 3, 2015 at 17:43
  • Are they in a stack?
    – Ron Maupin
    Dec 3, 2015 at 17:44
  • No they are not stack... it is independent
    – Satish
    Dec 3, 2015 at 17:44
  • Then why is the interface on the first switch G2/0/1? The first number, 2, is the switch position in a stack.
    – Ron Maupin
    Dec 3, 2015 at 17:46

1 Answer 1

2

Edited to reflect new information in the question:

Based on your multiple edits which finally give the whole picture (I hope), you can try something like this, but using the switch stacking capability in the alternative configuration will give you a better solution.

Your connection to the ISP will need to be on the same subnet as the ISP.

SW1:

track 3 interface GigabitEthernet1/0/1 line-protocol
!
interface GigabitEthernet1/0/1
 description #Primary Link WTBB 1#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface GigabitEthernet1/0/2
 description #Link to switch 2#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface Vlan3
 ip address 10.107.25.11 255.255.255.240
 standby 30 ip 10.107.25.10
 standby 30 priority 105
 standby 30 preempt
 standby 30 track 3 decrement 10
 no shutdown
!

SW2:

track 3 interface GigabitEthernet1/0/1 line-protocol
!
interface GigabitEthernet1/0/1
 description #Primary Link WTBB 2#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface GigabitEthernet1/0/2
 description #Link to switch 1#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface Vlan3
 ip address 10.107.25.12 255.255.255.240
 standby 30 ip 10.107.25.10
 standby 30 priority 100
 standby 30 preempt
 standby 30 track 3 decrement 10
 no shutdown
!

This allows the ISP HSRP to work since the ISP routers need to be able to talk to each other on the same VLAN so that the ISP HSRP works.

Alternate (stacked) Configuration:

SW1/2 stack:

interface GigabitEthernet1/0/1
 description #Primary Link WTBB 1#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface GigabitEthernet2/0/1
 description #Primary Link WTBB 2#
 switchport
 switchport access vlan 3
 switchport mode access
 no shutdown
!
interface Vlan3
 ip address 10.107.25.10 255.255.255.240
 no shutdown
!

This configuration gives you all the benefits of the two separate switches but solves your problem of having two separate switches with separate IP addresses. The stack is configured as a single switch and is managed as a single device. Besides the data sharing, the 3850s can also do power sharing so that if one of them loses power, the other can keep both switches running. You will also save precious public IP addresses.

14
  • If i won't do HSRP then how ISP will sending traffic toward my SW? he need to put gateway in his routing table right?
    – Satish
    Dec 3, 2015 at 23:04
  • @Satish What are your subnet assignments from the ISP?
    – Ron Maupin
    Dec 3, 2015 at 23:19
  • you said in link failure HSRP will failover automatically, true but on ISP router they have to provide Revers route to my subnet behind the SW1 and SW2, My subnet is 71.200.10.X/24, if SW1 fiber cut then what will happen explain me?
    – Satish
    Dec 4, 2015 at 3:11
  • You are doling out the information bit-by-bit. How can you expect us to help you without the whole story? You didn't say anything about another subnet behind the subnet which we were discussing. I was working with the knowledge of a single subnet, but adding this other one changes things.
    – Ron Maupin
    Dec 4, 2015 at 13:20
  • I am sorry, i thought answer of this question will be easy so i didn't put any other info, but look like i was wrong. We have two link 1. Primary and 2. Standby or whatever you call so in case cable cut we won't be off the hook. How do i create network which can provide me failover in cable cut scenario or switch failed scenario
    – Satish
    Dec 4, 2015 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.