3

This is the topology My Network

As you can see routers and switches are all named out, so I will use those names to explain the issue.

First of all this network consists of VLANs, WANs running on EIGRP and DHCP configured routers, with that out of the way let me explain the issue.

The Right Router's network, specifically the one directly connected to the switch, works just fine! Those 2 different VLANs can communicate without any issue whatsoever, keep in mind there are 2 different VLANs on each network except for the Middle one... However, the moment one of the PCs on the Right network (not VLAN but network as a whole) try to communicate (ICMP/Ping) a PC on any of the other networks connected through a WAN connection, it simply fails. Keep in mind the other 2 Networks (Middle and Left) do not suffer from this issue whatsoever.

After using the simulation mode the issue was extremely, extremely weird... I first tried to ping from Right Router to Middle Router, and it worked no problems there... Then I tried to ping from a PC on the Right network to the Middle Router... Surprisingly enough, there is no destination IPv4 address in the packet!! What makes this even more weird is that when I try to ping the other way around, namely from the Middle Router to a PC on the Right network, the packet gets dropped immediately at the Middle Router, why? It doesn't know it's own IP address (and yes I did assign it an IP address on the serial port). Here are pictures in detail from Simulation mode:

From PC (Right Network) to Middle Router

From Middle Router to PC (Right Network)

Link for Middle Router Configuration http://pastebin.com/MAj8SaAm

hostname MRouter
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.0.0.2 255.255.255.252
!
interface Serial0/0/1
 ip address 10.1.1.1 255.255.255.252
 clock rate 128000
!
interface Serial0/1/0
 ip address 172.16.10.1 255.255.255.252
 clock rate 128000
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 5
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^C
This is the Middle Router
^C
!
!
!
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login
!
!
!
end

Link for Right Router Configuration http://pastebin.com/Wk8hCv9Z

hostname RRouter
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
ip dhcp pool Right
 network 172.16.1.0 255.255.255.240
 default-router 172.16.1.14
ip dhcp pool Left
 network 172.16.2.0 255.255.255.240
 default-router 172.16.2.14
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.16.1.14 255.255.255.240
!
interface FastEthernet0/0.25
 encapsulation dot1Q 25
 ip address 172.16.2.14 255.255.255.240
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
!
interface Serial0/0/1
 ip address 10.1.1.2 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 5
 network 172.16.0.0
 network 10.0.0.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^C
This is the Right Router
^C
!
!
!
!
line con 0
 password 7 0822455D0A16
 login
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
!
!
!
end
7
  • 1
    You need to edit your question to include the router configurations, otherwise we are just guessing where you may have gone wrong.
    – Ron Maupin
    Dec 5 '15 at 15:54
  • So basically show running config and copy that ? Or something else
    – Chessbrain
    Dec 5 '15 at 16:15
  • That would be good. You can clean up any public addresses.
    – Ron Maupin
    Dec 5 '15 at 16:17
  • Just posted it now, at the end of the post 2 links to pastebin with the configurations. Thanks for telling me what to do, first post ever here :P
    – Chessbrain
    Dec 5 '15 at 16:21
  • 1
    Try it with no auto-summary in the EIGRP configurations.
    – Ron Maupin
    Dec 5 '15 at 16:27
6

You have the 10.0.0.0/8 and 172.16.0.0/16 networks defined on both the middle and right routers. Using auto-summary on both makes each think they own those whole summarized networks, so they will not send any traffic in those networks toward the other router.

Using no auto-summary will allow each router to understand the more specific routes of each router.

1
  • I was scratching my head over this problem for the past 3-4 hours and nothing... Man you have no idea how grateful i am :D You're awesome :D
    – Chessbrain
    Dec 5 '15 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.