3

I have the following topology: Topology SW1 and SW2 have ip routing enabled. Both are able to ping the Loopback addresses: 2.2.2.2 and 2.2.2.3

Output for show ip route is:

SW1>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
S       2.2.2.3/32 [1/0] via 192.168.100.2
S       2.2.2.0/24 [1/0] via 192.168.100.20
C    192.168.200.0/24 is directly connected, Vlan200
C    192.168.100.0/24 is directly connected, Vlan1

and

SW2>show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 2 subnets
S       2.2.2.3 [1/0] via 192.168.100.30
S       2.2.2.0 [1/0] via 192.168.100.1
S    192.168.200.0/24 [1/0] via 192.168.100.1
C    192.168.100.0/24 is directly connected, Vlan1

Routers have their direct connected switches as default-gateway

Output for show run is:

R2#show run
Building configuration...

Current configuration : 865 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$maRc$UwddG0WVyNyDcklve0f5v1
enable password 7 110A1016141D5A
!
no aaa new-model
ip subnet-zero
no ip routing
!
!
!
no ip cef
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.20 255.255.255.0
 no ip route-cache
 speed auto
 full-duplex
 no mop enabled
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 no ip route-cache
 shutdown
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 192.168.100.1
ip http server
ip classless
!
!
!
!
!         
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 070C285F4D06
 login
!
!
end

and

R3:

R3#show run
Building configuration...

Current configuration : 727 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R3
!
enable secret 5 $1$xOJl$oNJ4x6DoBuCeLk8T8Jr5q/
enable password 7 110A1016141D5A
!
ip subnet-zero
no ip routing
!
!
!
call rsvp-sync
!
!
!
!
!         
!
!
!
interface Loopback1
 ip address 2.2.2.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.100.30 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 speed auto
 full-duplex
!
interface Serial0/0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
!
ip default-gateway 192.168.100.2
ip classless
ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 7 1511021F0725
 login
!
end

Why I'm not able to ping 2.2.2.3 from R2, neither 2.2.2.2 from R3? Thanks a lot for your help!

  • Can you provide a "sho ip route" from R2 nd R3?? – Orlando Gaetano Jan 8 '16 at 21:27
1

You don't have routes (either static or with a routing protocol) in the routers to reach the other router's loopback address.

Routers should not have a default gateway (this is a rookie mistake), and the switches can't be gateways, anyway, since they are layer-2 devices. You can put in static default routes, static specific routes, or run a routing protocol between the routers in order to share routes.

  • This is not a real PROD scenario. Just playing with the devices since I'm short on lab equipment. The idea is to use the routers as end hosts for this particular case and use the switches as L3 routers. – gmoraleda Dec 9 '15 at 16:00
  • You can only use switches as layer-3 switches if they are layer-3 switches and are properly configured. You didn't list any layer-3 configurations or routing tables for the switches, and that is more important than the router configurations and routing tables which you do list. – Ron Maupin Dec 9 '15 at 16:05
  • Can you provide a "sho ip route" from R2 nd R3??. – Orlando Gaetano Jan 8 '16 at 18:18
  • @OrlandoGaetano, I can't because it's not my equipment, but you should ask this on the question, not my answer. – Ron Maupin Jan 8 '16 at 18:20
  • @Ron Maupin, Ok, sorry – Orlando Gaetano Jan 8 '16 at 21:26
0

Are you sure both switches are forwarding IP packets?

Usually routers have 'ip routing' enabled.

Check all your devices for both 'ip routing' and 'ip cef':

sh run | i ip routing

sh run | i ip cef

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.